CVE-2017-4973 Cloud Foundry UAA Privilege Escalation
Attackers can elevate privileges via the UAA groups endpoint in Cloud Foundry, requiring an upgrade to secure the identity management service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-4973?
CVE-2017-4973 is a high-severity vulnerability in Cloud Foundry UAA, published on 13 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v257; UAA release 2.x versions prior to v2.7.4.14, 3.6.x versions prior to v3.6.8, 3.9.x versions prior to v3.9.10, and other versions prior to v3.15.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.12, 24.x versions prior to v24.7, and other versions prior to v30. A vulnerability has been identified with the groups endpoint in UAA allowing users to elevate their privileges.
Weakness: CWE-269
Which versions are affected by CVE-2017-4973?
8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 2.0.0 | 2.7.4.14 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 2.0.0 | 2.7.4.14 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.0.0 | 3.6.8 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.0.0 | 3.6.8 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.10.0 | 3.15.0 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.10.0 | 3.15.0 |
2 more packages
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.7.0 | 3.9.10 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.7.0 | 3.9.10 |
Products include Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry Cf, Pivotal Software Cloud Foundry Uaa.
How do I fix CVE-2017-4973?
Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 2.7.4.14, 3.6.8, 3.15.0 or 3.9.10.
Is CVE-2017-4973 being exploited?
There is no known exploitation of CVE-2017-4973 in the wild and no public exploit code.
Other vulnerabilities in Cloud Foundry UAA
- CVE-2016-6637 Cloud Foundry vulnerable to Cross-Site Request Forgery
- CVE-2016-4468 SQL injection in n/a
- CVE-2016-6651 Privilege escalation in n/a
- CVE-2016-3084 Cloud Foundry UAA reset password vulnerable to brute force attack
- CVE-2016-6659 Privilege escalation in Cloud Foundry v247 and earlier and UAA v3.9.2 & earlier and UAA bosh (uaa-release) v23 & earlier
Sources
Also known as GHSA-pgjc-gc7g-p2c6.