# CVE-2017-4973: Cloud Foundry UAA Privilege Escalation

> Attackers can elevate privileges via the UAA groups endpoint in Cloud Foundry, requiring an upgrade to secure the identity management service.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pgjc-gc7g-p2c6

## What is CVE-2017-4973?

CVE-2017-4973 is a high-severity vulnerability in Cloud Foundry UAA, published on 13 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v257; UAA release 2.x versions prior to v2.7.4.14, 3.6.x versions prior to v3.6.8, 3.9.x versions prior to v3.9.10, and other versions prior to v3.15.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.12, 24.x versions prior to v24.7, and other versions prior to v30. A vulnerability has been identified with the groups endpoint in UAA allowing users to elevate their privileges.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2017-4973?

8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 2.0.0 | 2.7.4.14 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 2.0.0 | 2.7.4.14 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.6.8 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.6.8 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 3.15.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 3.15.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.7.0 | 3.9.10 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.7.0 | 3.9.10 |

Products: Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry Cf, Pivotal Software Cloud Foundry Uaa.

## How do I fix CVE-2017-4973?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 2.7.4.14, 3.6.8, 3.15.0 or 3.9.10.

## Is CVE-2017-4973 being exploited?

There is no known exploitation of CVE-2017-4973 in the wild and no public exploit code.

## Other vulnerabilities in Cloud Foundry UAA

- [CVE-2016-6637](https://insights.sbomify.com/CVE-2016-6637/): Cloud Foundry vulnerable to Cross-Site Request Forgery (critical 9.6)
- [CVE-2016-4468](https://insights.sbomify.com/CVE-2016-4468/): SQL injection in n/a (high 8.8)
- [CVE-2016-6651](https://insights.sbomify.com/CVE-2016-6651/): Privilege escalation in n/a (high 8.8)
- [CVE-2016-3084](https://insights.sbomify.com/CVE-2016-3084/): Cloud Foundry UAA reset password vulnerable to brute force attack (high 8.1)
- [CVE-2016-6659](https://insights.sbomify.com/CVE-2016-6659/): Privilege escalation in Cloud Foundry v247 and earlier and UAA v3.9.2 & earlier and UAA bosh (uaa-release) v23 & earlier (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-4973 and fix it if it is affected.

What it is: CVE-2017-4973 is a high-severity vulnerability in Cloud Foundry UAA, published on 13 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-4973 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 2.0.0; fixed in 2.7.4.14
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 2.0.0; fixed in 2.7.4.14
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.6.8
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.6.8
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.15.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.15.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.7.0; fixed in 3.9.10
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.7.0; fixed in 3.9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-4973/ (Markdown: https://insights.sbomify.com/CVE-2017-4973/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-4973
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-4973
- OSV: https://osv.dev/vulnerability/CVE-2017-4973

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-4973/
Summaries are generated and may contain mistakes; the official description above is the record.
