CVE-2017-4974 Blind SQL Injection with privileged Cloud Foundry UAA endpoints
An authorized user can perform blind SQL injection to read the contents of the UAA database in Cloud Foundry.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-4974?
CVE-2017-4974 is a medium-severity SQL injection vulnerability in Cloud Foundry UAA, published on 13 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v258; UAA release 2.x versions prior to v2.7.4.15, 3.6.x versions prior to v3.6.9, 3.9.x versions prior to v3.9.11, and other versions prior to v3.16.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.13, 24.x versions prior to v24.8, and other versions prior to v30.1. An authorized user can use a blind SQL injection attack to query the contents of the UAA database, aka "Blind SQL Injection with privileged UAA endpoints."
Weakness: CWE-89
Which versions are affected by CVE-2017-4974?
8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 2.0.0 | 2.7.4.15 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 2.0.0 | 2.7.4.15 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.0.0 | 3.6.9 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.0.0 | 3.6.9 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.10.0 | 3.16.0 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.10.0 | 3.16.0 |
2 more packages
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.7.0 | 3.9.11 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.7.0 | 3.9.11 |
Products include Cloudfoundry Cf-Release, Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry Uaa.
How do I fix CVE-2017-4974?
Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 2.7.4.15, 3.6.9, 3.16.0 or 3.9.11.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2017-4974 being exploited?
There is no known exploitation of CVE-2017-4974 in the wild and no public exploit code.
Other vulnerabilities in Cloud Foundry UAA
- CVE-2015-5171 Cloud Foundry Runtime Insufficient Session Expiration vulnerability
- CVE-2015-5172 Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password
- CVE-2016-8218 Auth bypass in Cloud Foundry
- CVE-2017-4992 Cloud Foundry UAA privilege escalation with user invitations
- CVE-2016-6658 Information disclosure in n/a
Sources
Also known as GHSA-cw9c-v3v2-99hm.