# CVE-2017-4974: Blind SQL Injection with privileged Cloud Foundry UAA endpoints

> An authorized user can perform blind SQL injection to read the contents of the UAA database in Cloud Foundry.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cw9c-v3v2-99hm

## What is CVE-2017-4974?

CVE-2017-4974 is a medium-severity SQL injection vulnerability in Cloud Foundry UAA, published on 13 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v258; UAA release 2.x versions prior to v2.7.4.15, 3.6.x versions prior to v3.6.9, 3.9.x versions prior to v3.9.11, and other versions prior to v3.16.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.13, 24.x versions prior to v24.8, and other versions prior to v30.1. An authorized user can use a blind SQL injection attack to query the contents of the UAA database, aka "Blind SQL Injection with privileged UAA endpoints."

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2017-4974?

8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 2.0.0 | 2.7.4.15 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 2.0.0 | 2.7.4.15 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.6.9 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.6.9 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 3.16.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 3.16.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.7.0 | 3.9.11 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.7.0 | 3.9.11 |

Products: Cloudfoundry Cf-Release, Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry Uaa.

## How do I fix CVE-2017-4974?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 2.7.4.15, 3.6.9, 3.16.0 or 3.9.11.

## Is CVE-2017-4974 being exploited?

There is no known exploitation of CVE-2017-4974 in the wild and no public exploit code.

## Other vulnerabilities in Cloud Foundry UAA

- [CVE-2015-5171](https://insights.sbomify.com/CVE-2015-5171/): Cloud Foundry Runtime Insufficient Session Expiration vulnerability (critical 9.8)
- [CVE-2015-5172](https://insights.sbomify.com/CVE-2015-5172/): Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password (critical 9.8)
- [CVE-2016-8218](https://insights.sbomify.com/CVE-2016-8218/): Auth bypass in Cloud Foundry (critical 9.8)
- [CVE-2017-4992](https://insights.sbomify.com/CVE-2017-4992/): Cloud Foundry UAA privilege escalation with user invitations (critical 9.8)
- [CVE-2016-6658](https://insights.sbomify.com/CVE-2016-6658/): Information disclosure in n/a (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-4974 and fix it if it is affected.

What it is: CVE-2017-4974 is a medium-severity SQL injection vulnerability in Cloud Foundry UAA, published on 13 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-4974 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 2.0.0; fixed in 2.7.4.15
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 2.0.0; fixed in 2.7.4.15
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.6.9
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.6.9
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.16.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.16.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.7.0; fixed in 3.9.11
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.7.0; fixed in 3.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-4974/ (Markdown: https://insights.sbomify.com/CVE-2017-4974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-4974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-4974
- OSV: https://osv.dev/vulnerability/CVE-2017-4974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-4974/
Summaries are generated and may contain mistakes; the official description above is the record.
