# CVE-2017-4992: Cloud Foundry UAA privilege escalation with user invitations

> Attackers can escalate privileges and take over accounts via arbitrary password reset in Cloud Foundry UAA user invitations.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jcmh-x32v-7mgf

## What is CVE-2017-4992?

CVE-2017-4992 is a critical vulnerability in Cloud Foundry, published on 13 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v261; UAA release 2.x versions prior to v2.7.4.17, 3.6.x versions prior to v3.6.11, 3.9.x versions prior to v3.9.13, and other versions prior to v4.2.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.15, 24.x versions prior to v24.10, 30.x versions prior to 30.3, and other versions prior to v37. There is privilege escalation (arbitrary password reset) with user invitations.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2017-4992?

8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 2.0.0 | 2.7.4.17 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 2.0.0 | 2.7.4.17 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.6.11 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.0.0 | 3.6.11 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 4.2.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 4.2.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.7.0 | 3.9.13 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.7.0 | 3.9.13 |

Products: Cloudfoundry Cf-Release, Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry Uaa.

## How do I fix CVE-2017-4992?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 2.7.4.17, 3.6.11, 4.2.0 or 3.9.13.

## Is CVE-2017-4992 being exploited?

There is no known exploitation of CVE-2017-4992 in the wild and no public exploit code.

## Other vulnerabilities in Cloud Foundry

- [CVE-2015-5171](https://insights.sbomify.com/CVE-2015-5171/): Cloud Foundry Runtime Insufficient Session Expiration vulnerability (critical 9.8)
- [CVE-2015-5172](https://insights.sbomify.com/CVE-2015-5172/): Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password (critical 9.8)
- [CVE-2016-8218](https://insights.sbomify.com/CVE-2016-8218/): Auth bypass in Cloud Foundry (critical 9.8)
- [CVE-2016-6658](https://insights.sbomify.com/CVE-2016-6658/): Information disclosure in n/a (critical 9.6)
- [CVE-2015-5170](https://insights.sbomify.com/CVE-2015-5170/): Cloud Foundry Runtime Cross-Site Request Forgery vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-4992 and fix it if it is affected.

What it is: CVE-2017-4992 is a critical vulnerability in Cloud Foundry, published on 13 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-4992 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 2.0.0; fixed in 2.7.4.17
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 2.0.0; fixed in 2.7.4.17
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.6.11
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.6.11
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 4.2.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 4.2.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.7.0; fixed in 3.9.13
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.7.0; fixed in 3.9.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-4992/ (Markdown: https://insights.sbomify.com/CVE-2017-4992/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-4992
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-4992
- OSV: https://osv.dev/vulnerability/CVE-2017-4992

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-4992/
Summaries are generated and may contain mistakes; the official description above is the record.
