CVE-2017-4995 Deserialization of Untrusted Data in Spring Security
Attackers can execute arbitrary code via unsafe Jackson deserialization when Spring Security enables default typing on untrusted data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-4995?
CVE-2017-4995 is a high-severity unsafe deserialization vulnerability in Spring Security Spring Security 4.2.0.RELEASE 4.2.2.RELEASE and Spring Security 5.0.0.M1, published on 27 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Pivotal Spring Security 4.2.0.RELEASE through 4.2.2.RELEASE, and Spring Security 5.0.0.M1. When configured to enable default typing, Jackson contained a deserialization vulnerability that could lead to arbitrary code execution. Jackson fixed this vulnerability by blacklisting known "deserialization gadgets." Spring Security configures Jackson with global default typing enabled, which means that (through the previous exploit) arbitrary code could be executed if all of the following is true: (1) Spring Security's Jackson support is being leveraged by invoking SecurityJackson2Modules.getModules(ClassLoader) or SecurityJackson2Modules.enableDefaultTyping(ObjectMapper); (2) Jackson is used to deserialize data that is not trusted (Spring Security does not perform deserialization using Jackson, so this is an explicit choice of the user); and (3) there is an unknown (Jackson is not blacklisting it already) "deserialization gadget" that allows code execution present on the classpath. Jackson provides a blacklisting approach to protecting against this type of attack, but Spring Security should be proactive against blocking unknown "deserialization gadgets" when Spring Security enables default typing.
Weakness: CWE-502
Which versions are affected by CVE-2017-4995?
4 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security:spring-security-core Maven | From 4.2.0.RELEASE | 4.2.3.RELEASE |
org.springframework.security:spring-security-core Maven | From 4.2.0.RELEASE | 4.2.3.RELEASE |
org.springframework.security:spring-security-core Maven | From 5.0.0.M1 | 5.0.0.M2 |
org.springframework.security:spring-security-core Maven | From 5.0.0.M1 | 5.0.0.M2 |
Products include Vmware Spring Security.
How do I fix CVE-2017-4995?
Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 4.2.3.RELEASE or 5.0.0.M2.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2017-4995 being exploited?
There is no known exploitation of CVE-2017-4995 in the wild and no public exploit code.
Other vulnerabilities in Spring Security Spring Security 4.2.0.RELEASE 4.2.2.RELEASE and Spring Security 5.0.0.M1
- CVE-2014-3527 Authorization Bypass in Spring Security
- CVE-2026-59354 Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata
- CVE-2026-59270 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces
- CVE-2026-22732 Under Some Conditions Spring Security HTTP Headers Are not Written
- CVE-2023-34034 Access Control Bypass in Spring Security
Sources
Also known as GHSA-vhrg-v3cv-p247.