# CVE-2017-4995: Deserialization of Untrusted Data in Spring Security

> Attackers can execute arbitrary code via unsafe Jackson deserialization when Spring Security enables default typing on untrusted data.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vhrg-v3cv-p247

## What is CVE-2017-4995?

CVE-2017-4995 is a high-severity unsafe deserialization vulnerability in Spring Security Spring Security 4.2.0.RELEASE 4.2.2.RELEASE and Spring Security 5.0.0.M1, published on 27 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Pivotal Spring Security 4.2.0.RELEASE through 4.2.2.RELEASE, and Spring Security 5.0.0.M1. When configured to enable default typing, Jackson contained a deserialization vulnerability that could lead to arbitrary code execution. Jackson fixed this vulnerability by blacklisting known "deserialization gadgets." Spring Security configures Jackson with global default typing enabled, which means that (through the previous exploit) arbitrary code could be executed if all of the following is true: (1) Spring Security's Jackson support is being leveraged by invoking SecurityJackson2Modules.getModules(ClassLoader) or SecurityJackson2Modules.enableDefaultTyping(ObjectMapper); (2) Jackson is used to deserialize data that is not trusted (Spring Security does not perform deserialization using Jackson, so this is an explicit choice of the user); and (3) there is an unknown (Jackson is not blacklisting it already) "deserialization gadget" that allows code execution present on the classpath. Jackson provides a blacklisting approach to protecting against this type of attack, but Spring Security should be proactive against blocking unknown "deserialization gadgets" when Spring Security enables default typing.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-4995?

4 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 4.2.0.RELEASE | 4.2.3.RELEASE |
| `org.springframework.security:spring-security-core` | Maven | From 4.2.0.RELEASE | 4.2.3.RELEASE |
| `org.springframework.security:spring-security-core` | Maven | From 5.0.0.M1 | 5.0.0.M2 |
| `org.springframework.security:spring-security-core` | Maven | From 5.0.0.M1 | 5.0.0.M2 |

Products: Vmware Spring Security.

## How do I fix CVE-2017-4995?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 4.2.3.RELEASE or 5.0.0.M2.

## Is CVE-2017-4995 being exploited?

There is no known exploitation of CVE-2017-4995 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security Spring Security 4.2.0.RELEASE 4.2.2.RELEASE and Spring Security 5.0.0.M1

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-4995 and fix it if it is affected.

What it is: CVE-2017-4995 is a high-severity unsafe deserialization vulnerability in Spring Security Spring Security 4.2.0.RELEASE 4.2.2.RELEASE and Spring Security 5.0.0.M1, published on 27 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-4995 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 4.2.0.RELEASE; fixed in 4.2.3.RELEASE
- org.springframework.security:spring-security-core (Maven): affected from 4.2.0.RELEASE; fixed in 4.2.3.RELEASE
- org.springframework.security:spring-security-core (Maven): affected from 5.0.0.M1; fixed in 5.0.0.M2
- org.springframework.security:spring-security-core (Maven): affected from 5.0.0.M1; fixed in 5.0.0.M2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-4995/ (Markdown: https://insights.sbomify.com/CVE-2017-4995/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-4995
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-4995
- OSV: https://osv.dev/vulnerability/CVE-2017-4995

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-4995/
Summaries are generated and may contain mistakes; the official description above is the record.
