{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 6 products.","exploited":"There is no known exploitation of CVE-2017-5029 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.7.2 or later.","what":"CVE-2017-5029 is a high-severity vulnerability in Debian Debian Linux, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-5029 and fix it if it is affected.\n\nWhat it is: CVE-2017-5029 is a high-severity vulnerability in Debian Debian Linux, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-5029 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.7.2\n- nokogiri (RubyGems): affected all versions; fixed in 1.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-5029/ (Markdown: https://insights.sbomify.com/CVE-2017-5029/index.md)","id":"CVE-2017-5029","markdown":"https://insights.sbomify.com/CVE-2017-5029/index.md","name":"CVE-2017-5029","record":{"aliases":["ALPINE-CVE-2017-5029","DEBIAN-CVE-2017-5029","DLA-866-1","GHSA-pf6m-fxpq-fg8v","MGASA-2017-0125","UBUNTU-CVE-2017-5029"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Google Chrome","requires_auth":"none","summary":"A remote attacker can execute arbitrary code via a crafted HTML page due to an integer overflow in libxslt within Google Chrome.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Chrome","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"chrome","vendor":"google"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"},{"product":"libxslt","vendor":"xmlsoft"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Blink in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108 for Android, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Nokogiri implementation of libxslt lacks integer overflow checks","id":"CVE-2017-5029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","google:chrome","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"integer_overflow","year":"2017"},"n_packages":2,"n_references":7,"next":{"headline":"Google Chromium V8 Memory Corruption","id":"CVE-2017-5030"},"packages":[{"ecosystem":"RubyGems","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-pf6m-fxpq-fg8v"},{"ecosystem":"RubyGems","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-pf6m-fxpq-fg8v"}],"prev":{"headline":"Information disclosure in Chrome","id":"CVE-2017-5028"},"products":["Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and 57.0.2987.108 for Android"],"published":"2017-04-24","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A remote attacker can execute arbitrary code via a crafted HTML page due to an integer overflow in libxslt within Google Chrome.","url":"https://insights.sbomify.com/CVE-2017-5029/"}