CVE-2017-5197 Silverstripe CMS XSS Vulnerability
Attackers can execute arbitrary JavaScript in victim browsers via crafted page names in SilverStripe CMS, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-5197?
CVE-2017-5197 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 6 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
There is XSS in SilverStripe CMS before 3.4.4 and 3.5.x before 3.5.2. The attack vector is a page name. An example payload is a crafted JavaScript event handler within a malformed SVG element.
Weakness: CWE-79
Which versions are affected by CVE-2017-5197?
4 open source packages ship an affected version, including silverstripe/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/cms Packagist | All versions | 3.4.4 |
silverstripe/cms Packagist | All versions | 3.4.4 |
silverstripe/cms Packagist | From 3.5.0 | 3.5.2 |
silverstripe/cms Packagist | From 3.5.0 | 3.5.2 |
Products include Silverstripe Silverstripe.
How do I fix CVE-2017-5197?
Upgrade silverstripe/cms to a fixed version for your release line: 3.4.4 or 3.5.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-5197 being exploited?
There is no known exploitation of CVE-2017-5197 in the wild and no public exploit code.
Other vulnerabilities in Silverstripe Silverstripe
Sources
Also known as GHSA-xmjh-wjc5-wg4h.