# CVE-2017-5223: Local file disclosure in PHPMailer

> Attackers can read arbitrary local files by supplying crafted HTML to PHPMailer's msgHTML method without a base directory, exposing sensitive data.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-5223, DLA-817-1, GHSA-4x5h-cr29-fhp6, UBUNTU-CVE-2017-5223

## What is CVE-2017-5223?

CVE-2017-5223 is a medium-severity vulnerability in n/a, published on 16 Jan 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in PHPMailer before 5.2.22. PHPMailer's msgHTML method applies transformations to an HTML document to make it usable as an email message body. One of the transformations is to convert relative image URLs into attachments using a script-provided base directory. If no base directory is provided, it resolves to /, meaning that relative image URLs get treated as absolute local file paths and added as attachments. To form a remote vulnerability, the msgHTML method must be called, passed an unfiltered, user-supplied HTML document, and must not set a base directory.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-5223?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.22 |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.22 |

Products: Phpmailer Project Phpmailer.

## How do I fix CVE-2017-5223?

Upgrade phpmailer/phpmailer to 5.2.22 or later.

## Is CVE-2017-5223 being exploited?

There is no known exploitation of CVE-2017-5223 in the wild and no public exploit code.

Public exploit code:

- https://github.com/cscli/CVE-2017-5223 (github_poc): https://github.com/cscli/CVE-2017-5223
- PHPMailer < 5.2.21 - Local File Disclosure (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2020-36326](https://insights.sbomify.com/CVE-2020-36326/): Object injection in PHPMailer/PHPMailer (critical 9.8)
- [CVE-2017-11503](https://insights.sbomify.com/CVE-2017-11503/): Cross-site scripting in PHPMailer (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5223 and fix it if it is affected.

What it is: CVE-2017-5223 is a medium-severity vulnerability in n/a, published on 16 Jan 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-5223 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.22
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5223/ (Markdown: https://insights.sbomify.com/CVE-2017-5223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5223
- OSV: https://osv.dev/vulnerability/CVE-2017-5223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5223/
Summaries are generated and may contain mistakes; the official description above is the record.
