{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-5330 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-5330 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 27 Mar 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-5330 and fix it if it is affected.\n\nWhat it is: CVE-2017-5330 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 27 Mar 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-5330 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-5330/ (Markdown: https://insights.sbomify.com/CVE-2017-5330/index.md)","id":"CVE-2017-5330","markdown":"https://insights.sbomify.com/CVE-2017-5330/index.md","name":"CVE-2017-5330","record":{"aliases":["DEBIAN-CVE-2017-5330","GHSA-fvqq-96pq-qq6m","UBUNTU-CVE-2017-5330","openSUSE-SU-2017:0140-1","openSUSE-SU-2017:0150-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"KDE Ark archiver","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by tricking users into opening a malicious archive containing an executable in KDE Ark.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"ark","vendor":"kde"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.","ecosystems":["SUSE:Package Hub 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2017-5330","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"command_injection","year":"2017"},"n_packages":2,"n_references":6,"next":{"headline":"Integer overflow in icoutils","id":"CVE-2017-5331"},"packages":[{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["15.12.3-8.1"],"introduced":["0"],"last_affected":[],"package":"ark","purl":"pkg:rpm/suse/ark\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2017:0140-1"},{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["15.12.3-8.1"],"introduced":["0"],"last_affected":[],"package":"ark","purl":"pkg:rpm/suse/ark\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2017:0150-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-5329"},"products":["n/a"],"published":"2017-03-27","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code by tricking users into opening a malicious archive containing an executable in KDE Ark.","url":"https://insights.sbomify.com/CVE-2017-5330/"}