{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-5357 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-5357 is a high-severity use after free vulnerability in Fedoraproject Fedora, published on 16 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-5357 and fix it if it is affected.\n\nWhat it is: CVE-2017-5357 is a high-severity use after free vulnerability in Fedoraproject Fedora, published on 16 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-5357 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-5357/ (Markdown: https://insights.sbomify.com/CVE-2017-5357/index.md)","id":"CVE-2017-5357","markdown":"https://insights.sbomify.com/CVE-2017-5357/index.md","name":"CVE-2017-5357","record":{"aliases":["GHSA-3vq6-cwx3-x994","SUSE-SU-2019:14005-1","SUSE-SU-2020:1608-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GNU ed text editor","requires_auth":"none","summary":"Attackers can cause a denial of service via a crash in GNU ed triggered by an invalid free when processing malformed commands.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"ed","vendor":"gnu"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"regex.c in GNU ed before 1.14.1 allows attackers to cause a denial of service (crash) via a malformed command, which triggers an invalid free.","ecosystems":["SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server 12 SP4","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2017-5357","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"use_after_free","year":"2017"},"n_packages":6,"n_references":7,"next":{"headline":"Memory corruption in n/a","id":"CVE-2017-5358"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["0.2-1001.30.3.4"],"introduced":["0"],"last_affected":[],"package":"ed","purl":"pkg:rpm/suse/ed\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2019:14005-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP4","fixed":["1.9-4.4.5"],"introduced":["0"],"last_affected":[],"package":"ed","purl":"pkg:rpm/suse/ed\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP4","source":"SUSE-SU-2020:1608-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["1.9-4.4.5"],"introduced":["0"],"last_affected":[],"package":"ed","purl":"pkg:rpm/suse/ed\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2020:1608-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["0.2-1001.30.3.4"],"introduced":["0"],"last_affected":[],"package":"ed","purl":"pkg:rpm/suse/ed\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2019:14005-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP4","fixed":["1.9-4.4.5"],"introduced":["0"],"last_affected":[],"package":"ed","purl":"pkg:rpm/suse/ed\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP4","source":"SUSE-SU-2020:1608-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["1.9-4.4.5"],"introduced":["0"],"last_affected":[],"package":"ed","purl":"pkg:rpm/suse/ed\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2020:1608-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2017-5356"},"products":["n/a"],"published":"2017-02-16","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause a denial of service via a crash in GNU ed triggered by an invalid free when processing malformed commands.","url":"https://insights.sbomify.com/CVE-2017-5357/"}