{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-5495 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-5495 is a high-severity denial of service vulnerability in n/a, published on 24 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-5495 and fix it if it is affected.\n\nWhat it is: CVE-2017-5495 is a high-severity denial of service vulnerability in n/a, published on 24 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-5495 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-5495/ (Markdown: https://insights.sbomify.com/CVE-2017-5495/index.md)","id":"CVE-2017-5495","markdown":"https://insights.sbomify.com/CVE-2017-5495/index.md","name":"CVE-2017-5495","record":{"aliases":["ALPINE-CVE-2017-5495","GHSA-6629-rcxv-r9v7","MGASA-2017-0071","UBUNTU-CVE-2017-5495"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Quagga routing software","requires_auth":"none","summary":"Unbounded memory allocation in Quagga's telnet CLI allows remote attackers to cause denial of service if the interface is enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"quagga","vendor":"quagga"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"All versions of Quagga, 0.93 through 1.1.0, are vulnerable to an unbounded memory allocation in the telnet 'vty' CLI, leading to a Denial-of-Service of Quagga daemons, or even the entire host. When Quagga daemons are configured with their telnet CLI enabled, anyone who can connect to the TCP ports can trigger this vulnerability, prior to authentication. Most distributions restrict the Quagga telnet interface to local access only by default. The Quagga telnet interface 'vty' input buffer grows automatically, without bound, so long as a newline is not entered. This allows an attacker to cause the Quagga daemon to allocate unbounded memory by sending very long strings without a newline. Eventually the daemon is terminated by the system, or the system itself runs out of memory. This is fixed in Quagga 1.1.1 and Free Range Routing (FRR) Protocol Suite 2017-01-10.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2017-5495","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":0,"n_references":6,"next":{"headline":"Information disclosure in n/a","id":"CVE-2017-5496"},"packages":[],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-5494"},"products":["n/a"],"published":"2017-01-24","related":[{"cvss_score":8.2,"headline":"Denial of service in Protocol","id":"CVE-2017-3224","kev_date_added":null,"published":"2018-07-24"},{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2021-44038","kev_date_added":null,"published":"2021-11-19"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2011-3327","kev_date_added":null,"published":"2011-10-10"},{"cvss_score":6.5,"headline":"Memory corruption in n/a","id":"CVE-2010-2948","kev_date_added":null,"published":"2010-09-10"},{"cvss_score":6.3,"headline":"Denial of service in n/a","id":"CVE-2007-1995","kev_date_added":null,"published":"2007-04-12"},{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2012-0255","kev_date_added":null,"published":"2012-04-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Unbounded memory allocation in Quagga's telnet CLI allows remote attackers to cause denial of service if the interface is enabled.","url":"https://insights.sbomify.com/CVE-2017-5495/"}