# CVE-2017-5495: Denial of service in n/a

> Unbounded memory allocation in Quagga's telnet CLI allows remote attackers to cause denial of service if the interface is enabled.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2017
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2017-5495, GHSA-6629-rcxv-r9v7, MGASA-2017-0071, UBUNTU-CVE-2017-5495

## What is CVE-2017-5495?

CVE-2017-5495 is a high-severity denial of service vulnerability in n/a, published on 24 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of Quagga, 0.93 through 1.1.0, are vulnerable to an unbounded memory allocation in the telnet 'vty' CLI, leading to a Denial-of-Service of Quagga daemons, or even the entire host. When Quagga daemons are configured with their telnet CLI enabled, anyone who can connect to the TCP ports can trigger this vulnerability, prior to authentication. Most distributions restrict the Quagga telnet interface to local access only by default. The Quagga telnet interface 'vty' input buffer grows automatically, without bound, so long as a newline is not entered. This allows an attacker to cause the Quagga daemon to allocate unbounded memory by sending very long strings without a newline. Eventually the daemon is terminated by the system, or the system itself runs out of memory. This is fixed in Quagga 1.1.1 and Free Range Routing (FRR) Protocol Suite 2017-01-10.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2017-5495?

It affects 1 product.


Products: Quagga Quagga.

## How do I fix CVE-2017-5495?

Upgrade to a fixed version.

## Is CVE-2017-5495 being exploited?

There is no known exploitation of CVE-2017-5495 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-3224](https://insights.sbomify.com/CVE-2017-3224/): Denial of service in Protocol (high 8.2)
- [CVE-2021-44038](https://insights.sbomify.com/CVE-2021-44038/): Privilege escalation in n/a (high 7.8)
- [CVE-2011-3327](https://insights.sbomify.com/CVE-2011-3327/): Memory corruption in n/a (high 7.5)
- [CVE-2010-2948](https://insights.sbomify.com/CVE-2010-2948/): Memory corruption in n/a (medium 6.5)
- [CVE-2007-1995](https://insights.sbomify.com/CVE-2007-1995/): Denial of service in n/a (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5495 and fix it if it is affected.

What it is: CVE-2017-5495 is a high-severity denial of service vulnerability in n/a, published on 24 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-5495 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5495/ (Markdown: https://insights.sbomify.com/CVE-2017-5495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5495
- OSV: https://osv.dev/vulnerability/CVE-2017-5495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5495/
Summaries are generated and may contain mistakes; the official description above is the record.
