# CVE-2017-5617: Server Side Request Forgery in svgSalamander

> Remote attackers can perform server-side request forgery via SVG xlink:href attributes in applications using the SVG Salamander library.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-5617, DLA-816-1, DSA-3781-1, GHSA-h3wv-47xm-4mg6, MGASA-2019-0160, UBUNTU-CVE-2017-5617

## What is CVE-2017-5617?

CVE-2017-5617 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 16 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The SVG Salamander (aka svgSalamander) library, when used in a web application, allows remote attackers to conduct server-side request forgery (SSRF) attacks via an xlink:href attribute in an SVG file.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2017-5617?

2 open source packages ship an affected version, including com.kitfox.svg:svg-salamander. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.kitfox.svg:svg-salamander` | Maven | All versions | 1.1.2 |
| `com.kitfox.svg:svg-salamander` | Maven | All versions | 1.1.2 |

Products: Debian Debian Linux, Kitfox Svg Salamander.

## How do I fix CVE-2017-5617?

Upgrade com.kitfox.svg:svg-salamander to 1.1.2 or later.

## Is CVE-2017-5617 being exploited?

There is no known exploitation of CVE-2017-5617 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5617 and fix it if it is affected.

What it is: CVE-2017-5617 is a high-severity server-side request forgery vulnerability in Debian Debian Linux, published on 16 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-5617 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.kitfox.svg:svg-salamander (Maven): affected all versions; fixed in 1.1.2
- com.kitfox.svg:svg-salamander (Maven): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5617/ (Markdown: https://insights.sbomify.com/CVE-2017-5617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5617
- OSV: https://osv.dev/vulnerability/CVE-2017-5617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5617/
Summaries are generated and may contain mistakes; the official description above is the record.
