CVE-2017-5635 Improper Authentication In Apache NiFi

High 7.5 Published Updated

In clustered Apache NiFi, anonymous requests may incorrectly inherit the originating node's identity, allowing unauthorized access or privilege escalation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-5635?

CVE-2017-5635 is a high-severity authentication bypass vulnerability in Apache Nifi, published on 19 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, if an anonymous user request is replicated to another node, the originating node identity is used rather than the "anonymous" user.

Weakness: CWE-287

Which versions are affected by CVE-2017-5635?

4 open source packages ship an affected version, including org.apache.nifi:nifi. It affects 1 product.

PackageAffectedFixed in
org.apache.nifi:nifi MavenAll versions0.7.2
org.apache.nifi:nifi MavenAll versions0.7.2
org.apache.nifi:nifi MavenFrom 1.0.01.1.2
org.apache.nifi:nifi MavenFrom 1.0.01.1.2

Products include Apache Nifi.

How do I fix CVE-2017-5635?

Upgrade org.apache.nifi:nifi to a fixed version for your release line: 0.7.2 or 1.1.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2017-5635 being exploited?

There is no known exploitation of CVE-2017-5635 in the wild and no public exploit code.

All Apache Nifi vulnerabilities

Sources

Also known as GHSA-jgj9-6v78-6g8m.

Is CVE-2017-5635 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free