CVE-2017-5636 Injection in Apache NiFi

Critical 9.8 Published Updated

Attackers can impersonate users and gain permissions in Apache NiFi clusters via crafted usernames in proxy chain serialization.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-5636?

CVE-2017-5636 is a critical unsafe deserialization vulnerability in Apache Nifi, published on 19 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, the proxy chain serialization/deserialization is vulnerable to an injection attack where a carefully crafted username could impersonate another user and gain their permissions on a replicated request to another node.

Weakness: CWE-74

Which versions are affected by CVE-2017-5636?

4 open source packages ship an affected version, including org.apache.nifi:nifi. It affects 1 product.

PackageAffectedFixed in
org.apache.nifi:nifi MavenAll versions0.7.2
org.apache.nifi:nifi MavenAll versions0.7.2
org.apache.nifi:nifi MavenFrom 1.0.01.1.2
org.apache.nifi:nifi MavenFrom 1.0.01.1.2

Products include Apache Nifi.

How do I fix CVE-2017-5636?

Upgrade org.apache.nifi:nifi to a fixed version for your release line: 0.7.2 or 1.1.2.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2017-5636 being exploited?

There is no known exploitation of CVE-2017-5636 in the wild and no public exploit code.

All Apache Nifi vulnerabilities

Sources

Also known as GHSA-jrcc-7jf5-3pxg.

Is CVE-2017-5636 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free