CVE-2017-5637 Uncontrolled Resource Consumption in Apache ZooKeeper
Attackers can cause CPU exhaustion and service disruption in Apache ZooKeeper by abusing resource-intensive commands, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-5637?
CVE-2017-5637 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 10 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Two four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.
Which versions are affected by CVE-2017-5637?
4 open source packages ship an affected version, including org.apache.zookeeper:zookeeper. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.zookeeper:zookeeper Maven | From 3.4.0 | 3.4.10 |
org.apache.zookeeper:zookeeper Maven | From 3.4.0 | 3.4.10 |
org.apache.zookeeper:zookeeper Maven | From 3.5.0 | 3.5.3 |
org.apache.zookeeper:zookeeper Maven | From 3.5.0 | 3.5.3 |
Products include Apache Zookeeper, Debian Debian Linux.
How do I fix CVE-2017-5637?
Upgrade org.apache.zookeeper:zookeeper to a fixed version for your release line: 3.4.10 or 3.5.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-5637 being exploited?
There is no known exploitation of CVE-2017-5637 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Debian Debian Linux
- CVE-2024-51504 Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server
- CVE-2023-44981 Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication
- CVE-2016-5017 Memory corruption in n/a
- CVE-2026-59739 Apache ZooKeeper: Information disclosure via SetWatches reconnect replay
- CVE-2026-59969 Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode
Sources
Also known as DEBIAN-CVE-2017-5637, DLA-986-1, DSA-3871-1, GHSA-7cwj-j333-x7f7, UBUNTU-CVE-2017-5637.