{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.zookeeper:zookeeper. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-5637 in the wild and no public exploit code.","fix":"Upgrade org.apache.zookeeper:zookeeper to a fixed version for your release line: 3.4.10 or 3.5.3.","what":"CVE-2017-5637 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 10 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-5637 and fix it if it is affected.\n\nWhat it is: CVE-2017-5637 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 10 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-5637 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.zookeeper:zookeeper (Maven): affected from 3.4.0; fixed in 3.4.10\n- org.apache.zookeeper:zookeeper (Maven): affected from 3.4.0; fixed in 3.4.10\n- org.apache.zookeeper:zookeeper (Maven): affected from 3.5.0; fixed in 3.5.3\n- org.apache.zookeeper:zookeeper (Maven): affected from 3.5.0; fixed in 3.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-5637/ (Markdown: https://insights.sbomify.com/CVE-2017-5637/index.md)","id":"CVE-2017-5637","markdown":"https://insights.sbomify.com/CVE-2017-5637/index.md","name":"CVE-2017-5637","record":{"aliases":["DEBIAN-CVE-2017-5637","DLA-986-1","DSA-3871-1","GHSA-7cwj-j333-x7f7","UBUNTU-CVE-2017-5637"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ZooKeeper","requires_auth":"none","summary":"Attackers can cause CPU exhaustion and service disruption in Apache ZooKeeper by abusing resource-intensive commands, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"zookeeper","vendor":"apache"},{"product":"debian_linux","vendor":"debian"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"Two four letter word commands \"wchp/wchc\" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2017-07-02","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2017-07-02","kind":"exploitdb","ref":"42294","stars":null,"title":"Zookeeper 3.5.2 Client - Denial of Service"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Uncontrolled Resource Consumption in Apache ZooKeeper","id":"CVE-2017-5637","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"denial_of_service","year":"2017"},"n_packages":4,"n_references":12,"next":{"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638"},"packages":[{"ecosystem":"Maven","fixed":["3.4.10"],"introduced":["3.4.0"],"last_affected":[],"package":"org.apache.zookeeper:zookeeper","purl":null,"source":"GHSA-7cwj-j333-x7f7"},{"ecosystem":"Maven","fixed":["3.4.10"],"introduced":["3.4.0"],"last_affected":[],"package":"org.apache.zookeeper:zookeeper","purl":"pkg:maven/org.apache.zookeeper/zookeeper","source":"GHSA-7cwj-j333-x7f7"},{"ecosystem":"Maven","fixed":["3.5.3"],"introduced":["3.5.0"],"last_affected":[],"package":"org.apache.zookeeper:zookeeper","purl":null,"source":"GHSA-7cwj-j333-x7f7"},{"ecosystem":"Maven","fixed":["3.5.3"],"introduced":["3.5.0"],"last_affected":[],"package":"org.apache.zookeeper:zookeeper","purl":"pkg:maven/org.apache.zookeeper/zookeeper","source":"GHSA-7cwj-j333-x7f7"}],"prev":{"headline":"Injection in Apache NiFi","id":"CVE-2017-5636"},"products":["Apache ZooKeeper"],"published":"2017-10-10","related":[{"cvss_score":9.1,"headline":"Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server","id":"CVE-2024-51504","kev_date_added":null,"published":"2024-11-07"},{"cvss_score":9.1,"headline":"Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication","id":"CVE-2023-44981","kev_date_added":null,"published":"2023-10-11"},{"cvss_score":8.1,"headline":"Memory corruption in n/a","id":"CVE-2016-5017","kev_date_added":null,"published":"2016-09-21"},{"cvss_score":7.5,"headline":"Apache ZooKeeper: Information disclosure via SetWatches reconnect replay","id":"CVE-2026-59739","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":7.5,"headline":"Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode","id":"CVE-2026-59969","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":7.5,"headline":"Missing authorization in Apache ZooKeeper","id":"CVE-2026-79993","kev_date_added":null,"published":"2026-09-16"},{"cvss_score":7.5,"headline":"Missing Authorization in Apache ZooKeeper","id":"CVE-2018-8012","kev_date_added":null,"published":"2018-05-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause CPU exhaustion and service disruption in Apache ZooKeeper by abusing resource-intensive commands, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2017-5637/"}