# CVE-2017-5637: Uncontrolled Resource Consumption in Apache ZooKeeper

> Attackers can cause CPU exhaustion and service disruption in Apache ZooKeeper by abusing resource-intensive commands, requiring an upgrade to mitigate.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2017
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-5637, DLA-986-1, DSA-3871-1, GHSA-7cwj-j333-x7f7, UBUNTU-CVE-2017-5637

## What is CVE-2017-5637?

CVE-2017-5637 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 10 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Two four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2017-5637?

4 open source packages ship an affected version, including org.apache.zookeeper:zookeeper. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.4.0 | 3.4.10 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.4.0 | 3.4.10 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.5.0 | 3.5.3 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.5.0 | 3.5.3 |

Products: Apache Zookeeper, Debian Debian Linux.

## How do I fix CVE-2017-5637?

Upgrade org.apache.zookeeper:zookeeper to a fixed version for your release line: 3.4.10 or 3.5.3.

## Is CVE-2017-5637 being exploited?

There is no known exploitation of CVE-2017-5637 in the wild and no public exploit code.

Public exploit code:

- Zookeeper 3.5.2 Client - Denial of Service (exploitdb)

## Other vulnerabilities in Debian Debian Linux

- [CVE-2024-51504](https://insights.sbomify.com/CVE-2024-51504/): Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server (critical 9.1)
- [CVE-2023-44981](https://insights.sbomify.com/CVE-2023-44981/): Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication (critical 9.1)
- [CVE-2016-5017](https://insights.sbomify.com/CVE-2016-5017/): Memory corruption in n/a (high 8.1)
- [CVE-2026-59739](https://insights.sbomify.com/CVE-2026-59739/): Apache ZooKeeper: Information disclosure via SetWatches reconnect replay (high 7.5)
- [CVE-2026-59969](https://insights.sbomify.com/CVE-2026-59969/): Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5637 and fix it if it is affected.

What it is: CVE-2017-5637 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 10 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-5637 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zookeeper:zookeeper (Maven): affected from 3.4.0; fixed in 3.4.10
- org.apache.zookeeper:zookeeper (Maven): affected from 3.4.0; fixed in 3.4.10
- org.apache.zookeeper:zookeeper (Maven): affected from 3.5.0; fixed in 3.5.3
- org.apache.zookeeper:zookeeper (Maven): affected from 3.5.0; fixed in 3.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5637/ (Markdown: https://insights.sbomify.com/CVE-2017-5637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5637
- OSV: https://osv.dev/vulnerability/CVE-2017-5637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5637/
Summaries are generated and may contain mistakes; the official description above is the record.
