# CVE-2017-5638: Apache Struts Remote Code Execution

> Remote attackers can execute arbitrary commands via crafted HTTP headers in Apache Struts, requiring immediate upgrade to patched versions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV), used in ransomware
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2017
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-j77q-2qqg-6989

## What is CVE-2017-5638?

CVE-2017-5638 is a critical command injection vulnerability in Apache Struts, published on 11 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Jakarta Multipart parser in Apache Struts 2 2.3.x before 2.3.32 and 2.5.x before 2.5.10.1 has incorrect exception handling and error-message generation during file-upload attempts, which allows remote attackers to execute arbitrary commands via a crafted Content-Type, Content-Disposition, or Content-Length HTTP header, as exploited in the wild in March 2017 with a Content-Type header containing a #cmd= string.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2017-5638?

4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.3.0 | 2.3.32 |
| `org.apache.struts:struts2-core` | Maven | From 2.3.0 | 2.3.32 |
| `org.apache.struts:struts2-core` | Maven | From 2.5.0 | 2.5.10.1 |
| `org.apache.struts:struts2-core` | Maven | From 2.5.0 | 2.5.10.1 |

Products: Apache Struts, Arubanetworks Clearpass Policy Manager, Hp Server Automation, Ibm Storwize V3500 Firmware, Ibm Storwize V5000 Firmware, Ibm Storwize V7000 Firmware, Lenovo Storage V5030 Firmware, Netapp Oncommand Balance, Oracle Weblogic Server.

## How do I fix CVE-2017-5638?

Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.32 or 2.5.10.1. US federal agencies must fix it by 3 May 2022.

## Is CVE-2017-5638 being exploited?

Yes. Attackers have exploited CVE-2017-5638 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Public exploit code:

- An exploit for Apache Struts CVE-2017-5638 (github_poc): https://github.com/mazen160/struts-pwn
- Struts2 S2-045（CVE-2017-5638）Exp with GUI (github_poc): https://github.com/Flyteas/Struts2-045-Exp
- Demo Application and Exploit (github_poc): https://github.com/immunio/apache-struts2-CVE-2017-5638
- S2-045 漏洞 POC-TOOLS   CVE-2017-5638 (github_poc): https://github.com/jas502n/S2-045-EXP-POC-TOOLS
- Struts2 S2-045（CVE-2017-5638）Vulnerability environment - http://www.mottoin.com/97954.html (github_poc): https://github.com/PolarisLab/S2-045
- Example PoC Code for CVE-2017-5638 | Apache Struts Exploit  (github_poc): https://github.com/xsscx/cve-2017-5638

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-9805](https://insights.sbomify.com/CVE-2017-9805/): Apache Struts Deserialization of Untrusted Data (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5638 and fix it if it is affected.

What it is: CVE-2017-5638 is a critical command injection vulnerability in Apache Struts, published on 11 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2017-5638 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.3.0; fixed in 2.3.32
- org.apache.struts:struts2-core (Maven): affected from 2.3.0; fixed in 2.3.32
- org.apache.struts:struts2-core (Maven): affected from 2.5.0; fixed in 2.5.10.1
- org.apache.struts:struts2-core (Maven): affected from 2.5.0; fixed in 2.5.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5638/ (Markdown: https://insights.sbomify.com/CVE-2017-5638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5638
- OSV: https://osv.dev/vulnerability/CVE-2017-5638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5638/
Summaries are generated and may contain mistakes; the official description above is the record.
