{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.flex.blazeds:flex-messaging-core and org.apache.flex.blazeds:flex-messaging-remoting. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-5641 in the wild and no public exploit code.","fix":"Upgrade org.apache.flex.blazeds:flex-messaging-core to 4.7.3 or later.","what":"CVE-2017-5641 is a critical unsafe deserialization vulnerability in Apache Flex Blaze DS, published on 28 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-5641 and fix it if it is affected.\n\nWhat it is: CVE-2017-5641 is a critical unsafe deserialization vulnerability in Apache Flex Blaze DS, published on 28 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-5641 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.flex.blazeds:flex-messaging-core (Maven): affected all versions; fixed in 4.7.3\n- org.apache.flex.blazeds:flex-messaging-core (Maven): affected all versions; fixed in 4.7.3\n- org.apache.flex.blazeds:flex-messaging-remoting (Maven): affected all versions; fixed in 4.7.3\n- org.apache.flex.blazeds:flex-messaging-remoting (Maven): affected all versions; fixed in 4.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-5641/ (Markdown: https://insights.sbomify.com/CVE-2017-5641/index.md)","id":"CVE-2017-5641","markdown":"https://insights.sbomify.com/CVE-2017-5641/index.md","name":"CVE-2017-5641","record":{"aliases":["GHSA-w8v7-prhw-xjpw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java remoting library","requires_auth":"none","summary":"Attackers can achieve remote code execution by sending malicious AMF(X) objects to Apache Flex BlazeDS due to unrestricted deserialization.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"flex_blazeds","vendor":"apache"},{"product":"xp_command_view_advanced_edition","vendor":"hp"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Previous versions of Apache Flex BlazeDS (4.7.2 and earlier) did not restrict which types were allowed for AMF(X) object deserialization by default. During the deserialization process code is executed that for several known types has undesired side-effects. Other, unknown types may also exhibit such behaviors. One vector in the Java standard library exists that allows an attacker to trigger possibly further exploitable Java deserialization of untrusted data. Other known vectors in third party libraries can be used to trigger remote code execution.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Flex BlazeDS unsafe deserialization","id":"CVE-2017-5641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2017"},"n_packages":4,"n_references":8,"next":{"headline":"Misconfiguration in Apache Ambari","id":"CVE-2017-5642"},"packages":[{"ecosystem":"Maven","fixed":["4.7.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.flex.blazeds:flex-messaging-core","purl":null,"source":"GHSA-w8v7-prhw-xjpw"},{"ecosystem":"Maven","fixed":["4.7.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.flex.blazeds:flex-messaging-core","purl":"pkg:maven/org.apache.flex.blazeds/flex-messaging-core","source":"GHSA-w8v7-prhw-xjpw"},{"ecosystem":"Maven","fixed":["4.7.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.flex.blazeds:flex-messaging-remoting","purl":null,"source":"GHSA-w8v7-prhw-xjpw"},{"ecosystem":"Maven","fixed":["4.7.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.flex.blazeds:flex-messaging-remoting","purl":"pkg:maven/org.apache.flex.blazeds/flex-messaging-remoting","source":"GHSA-w8v7-prhw-xjpw"}],"prev":{"headline":"Auth bypass in Apache Impala","id":"CVE-2017-5640"},"products":["Apache Flex Blaze DS"],"published":"2017-12-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can achieve remote code execution by sending malicious AMF(X) objects to Apache Flex BlazeDS due to unrestricted deserialization.","url":"https://insights.sbomify.com/CVE-2017-5641/"}