# CVE-2017-5641: Apache Flex BlazeDS unsafe deserialization

> Attackers can achieve remote code execution by sending malicious AMF(X) objects to Apache Flex BlazeDS due to unrestricted deserialization.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-w8v7-prhw-xjpw

## What is CVE-2017-5641?

CVE-2017-5641 is a critical unsafe deserialization vulnerability in Apache Flex Blaze DS, published on 28 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Previous versions of Apache Flex BlazeDS (4.7.2 and earlier) did not restrict which types were allowed for AMF(X) object deserialization by default. During the deserialization process code is executed that for several known types has undesired side-effects. Other, unknown types may also exhibit such behaviors. One vector in the Java standard library exists that allows an attacker to trigger possibly further exploitable Java deserialization of untrusted data. Other known vectors in third party libraries can be used to trigger remote code execution.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-5641?

4 open source packages ship an affected version, including org.apache.flex.blazeds:flex-messaging-core and org.apache.flex.blazeds:flex-messaging-remoting. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.flex.blazeds:flex-messaging-core` | Maven | All versions | 4.7.3 |
| `org.apache.flex.blazeds:flex-messaging-core` | Maven | All versions | 4.7.3 |
| `org.apache.flex.blazeds:flex-messaging-remoting` | Maven | All versions | 4.7.3 |
| `org.apache.flex.blazeds:flex-messaging-remoting` | Maven | All versions | 4.7.3 |

Products: Apache Flex Blazeds, Hp Xp Command View Advanced Edition.

## How do I fix CVE-2017-5641?

Upgrade org.apache.flex.blazeds:flex-messaging-core to 4.7.3 or later.

## Is CVE-2017-5641 being exploited?

There is no known exploitation of CVE-2017-5641 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5641 and fix it if it is affected.

What it is: CVE-2017-5641 is a critical unsafe deserialization vulnerability in Apache Flex Blaze DS, published on 28 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-5641 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.flex.blazeds:flex-messaging-core (Maven): affected all versions; fixed in 4.7.3
- org.apache.flex.blazeds:flex-messaging-core (Maven): affected all versions; fixed in 4.7.3
- org.apache.flex.blazeds:flex-messaging-remoting (Maven): affected all versions; fixed in 4.7.3
- org.apache.flex.blazeds:flex-messaging-remoting (Maven): affected all versions; fixed in 4.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5641/ (Markdown: https://insights.sbomify.com/CVE-2017-5641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5641
- OSV: https://osv.dev/vulnerability/CVE-2017-5641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5641/
Summaries are generated and may contain mistakes; the official description above is the record.
