# CVE-2017-5644: Improper Restriction of Recursive Entity References in DTDs in Apache POI

> Remote attackers can cause denial of service via CPU consumption using crafted OOXML files in Apache POI.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-5644, GHSA-78vv-qj73-h9m5, UBUNTU-CVE-2017-5644

## What is CVE-2017-5644?

CVE-2017-5644 is a medium-severity vulnerability in Apache POI, published on 24 Mar 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Apache POI in versions prior to release 3.15 allows remote attackers to cause a denial of service (CPU consumption) via a specially crafted OOXML file, aka an XML Entity Expansion (XEE) attack.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2017-5644?

2 open source packages ship an affected version, including org.apache.poi:poi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.poi:poi` | Maven | All versions | 3.15 |
| `org.apache.poi:poi` | Maven | All versions | 3.15 |

Products: Apache Poi.

## How do I fix CVE-2017-5644?

Upgrade org.apache.poi:poi to 3.15 or later.

## Is CVE-2017-5644 being exploited?

There is no known exploitation of CVE-2017-5644 in the wild and no public exploit code.

## Other vulnerabilities in Apache POI

- [CVE-2017-12626](https://insights.sbomify.com/CVE-2017-12626/): Denial of Service in Apache POI (high 7.5)
- [CVE-2022-26336](https://insights.sbomify.com/CVE-2022-26336/): A carefully crafted TNEF file can cause an out of memory exception (medium 5.5)
- [CVE-2019-12415](https://insights.sbomify.com/CVE-2019-12415/): Improper Restriction of XML External Entity Reference in Apache POI (medium 5.5)
- [CVE-2016-5000](https://insights.sbomify.com/CVE-2016-5000/): Apache POI's XLSX2CSV Example XML External Entity (XXE) Vulnerability (medium 5.5)
- [CVE-2025-31672](https://insights.sbomify.com/CVE-2025-31672/): Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5644 and fix it if it is affected.

What it is: CVE-2017-5644 is a medium-severity vulnerability in Apache POI, published on 24 Mar 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-5644 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.poi:poi (Maven): affected all versions; fixed in 3.15
- org.apache.poi:poi (Maven): affected all versions; fixed in 3.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5644/ (Markdown: https://insights.sbomify.com/CVE-2017-5644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5644
- OSV: https://osv.dev/vulnerability/CVE-2017-5644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5644/
Summaries are generated and may contain mistakes; the official description above is the record.
