CVE-2017-5646 Apache Knox allows impersonation of users
Authenticated users can impersonate others via crafted URLs in WebHDFS, leading to privilege escalation and unauthorized data access.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-5646?
CVE-2017-5646 is a medium-severity authentication bypass vulnerability in Apache Knox, published on 26 May 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
For versions of Apache Knox from 0.2.0 to 0.11.0 - an authenticated user may use a specially crafted URL to impersonate another user while accessing WebHDFS through Apache Knox. This may result in escalated privileges and unauthorized data access. While this activity is audit logged and can be easily associated with the authenticated user, this is still a serious security issue. All users are recommended to upgrade to the Apache Knox 0.12.0 release.
Weakness: CWE-346
Which versions are affected by CVE-2017-5646?
2 open source packages ship an affected version, including org.apache.knox:gateway-provider-identity-assertion-common. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.knox:gateway-provider-identity-assertion-common Maven | From 0.2.0 | 0.12.0 |
org.apache.knox:gateway-provider-identity-assertion-common Maven | From 0.2.0 | 0.12.0 |
Products include Apache Knox.
How do I fix CVE-2017-5646?
Upgrade org.apache.knox:gateway-provider-identity-assertion-common to 0.12.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2017-5646 being exploited?
There is no known exploitation of CVE-2017-5646 in the wild and no public exploit code.
Other vulnerabilities in Apache Knox
Sources
Also known as GHSA-g3fc-8jv4-qmmv.