# CVE-2017-5646: Apache Knox allows impersonation of users

> Authenticated users can impersonate others via crafted URLs in WebHDFS, leading to privilege escalation and unauthorized data access.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-g3fc-8jv4-qmmv

## What is CVE-2017-5646?

CVE-2017-5646 is a medium-severity authentication bypass vulnerability in Apache Knox, published on 26 May 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

For versions of Apache Knox from 0.2.0 to 0.11.0 - an authenticated user may use a specially crafted URL to impersonate another user while accessing WebHDFS through Apache Knox. This may result in escalated privileges and unauthorized data access. While this activity is audit logged and can be easily associated with the authenticated user, this is still a serious security issue. All users are recommended to upgrade to the Apache Knox 0.12.0 release.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2017-5646?

2 open source packages ship an affected version, including org.apache.knox:gateway-provider-identity-assertion-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.knox:gateway-provider-identity-assertion-common` | Maven | From 0.2.0 | 0.12.0 |
| `org.apache.knox:gateway-provider-identity-assertion-common` | Maven | From 0.2.0 | 0.12.0 |

Products: Apache Knox.

## How do I fix CVE-2017-5646?

Upgrade org.apache.knox:gateway-provider-identity-assertion-common to 0.12.0 or later.

## Is CVE-2017-5646 being exploited?

There is no known exploitation of CVE-2017-5646 in the wild and no public exploit code.

## Other vulnerabilities in Apache Knox

- [CVE-2021-42357](https://insights.sbomify.com/CVE-2021-42357/): DOM based XSS Vulnerability in Apache Knox (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5646 and fix it if it is affected.

What it is: CVE-2017-5646 is a medium-severity authentication bypass vulnerability in Apache Knox, published on 26 May 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-5646 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.knox:gateway-provider-identity-assertion-common (Maven): affected from 0.2.0; fixed in 0.12.0
- org.apache.knox:gateway-provider-identity-assertion-common (Maven): affected from 0.2.0; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5646/ (Markdown: https://insights.sbomify.com/CVE-2017-5646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5646
- OSV: https://osv.dev/vulnerability/CVE-2017-5646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5646/
Summaries are generated and may contain mistakes; the official description above is the record.
