# CVE-2017-5657: Apache Archiva vulnerable to Cross Site Request Forgery

> Attackers can perform arbitrary actions on Apache Archiva with the victim's privileges via CSRF, potentially leading to administrative control.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hf4p-mhc8-x2gp

## What is CVE-2017-5657?

CVE-2017-5657 is a high-severity vulnerability in Apache Archiva, published on 22 May 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Several REST service endpoints of Apache Archiva are not protected against Cross Site Request Forgery (CSRF) attacks. A malicious site opened in the same browser as the archiva site, may send an HTML response that performs arbitrary actions on archiva services, with the same rights as the active archiva session (e.g. administrator rights).

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-5657?

2 open source packages ship an affected version, including org.apache.archiva:archiva. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.archiva:archiva` | Maven | All versions | 2.2.3 |
| `org.apache.archiva:archiva` | Maven | All versions | 2.2.3 |

Products: Apache Archiva.

## How do I fix CVE-2017-5657?

Upgrade org.apache.archiva:archiva to 2.2.3 or later.

## Is CVE-2017-5657 being exploited?

There is no known exploitation of CVE-2017-5657 in the wild and no public exploit code.

## Other vulnerabilities in Apache Archiva

- [CVE-2013-2251](https://insights.sbomify.com/CVE-2013-2251/): Apache Struts Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2016-4469](https://insights.sbomify.com/CVE-2016-4469/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2024-27138](https://insights.sbomify.com/CVE-2024-27138/): Apache Archiva: disabling user registration is not effective (high 7.5)
- [CVE-2024-27139](https://insights.sbomify.com/CVE-2024-27139/): Apache Archiva: incorrect authentication potentially leading to account takeover (high 7.5)
- [CVE-2022-40308](https://insights.sbomify.com/CVE-2022-40308/): Apache Archiva prior to 2.2.9 may allow the anonymous user to read arbitrary files (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5657 and fix it if it is affected.

What it is: CVE-2017-5657 is a high-severity vulnerability in Apache Archiva, published on 22 May 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-5657 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.archiva:archiva (Maven): affected all versions; fixed in 2.2.3
- org.apache.archiva:archiva (Maven): affected all versions; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5657/ (Markdown: https://insights.sbomify.com/CVE-2017-5657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5657
- OSV: https://osv.dev/vulnerability/CVE-2017-5657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5657/
Summaries are generated and may contain mistakes; the official description above is the record.
