{"answers":{"affected":"3 open source packages ship an affected version, including moin. It affects 4 products.","exploited":"There is no known exploitation of CVE-2017-5934 in the wild and no public exploit code.","fix":"Upgrade moin to 1.9.10 or later.","what":"CVE-2017-5934 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 15 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-5934 and fix it if it is affected.\n\nWhat it is: CVE-2017-5934 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 15 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-5934 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moin (PyPI): affected all versions; fixed in 1.9.10\n- moin (PyPI): affected all versions; fixed in 1.9.10\n- moin (PyPI): affected all versions; fixed in 1.9.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-5934/ (Markdown: https://insights.sbomify.com/CVE-2017-5934/index.md)","id":"CVE-2017-5934","markdown":"https://insights.sbomify.com/CVE-2017-5934/index.md","name":"CVE-2017-5934","record":{"aliases":["DLA-1546-1","DSA-4318-1","GHSA-42fp-4hm3-j8r7","PYSEC-2018-47","UBUNTU-CVE-2017-5934","USN-3794-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MoinMoin wiki","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the GUI editor link dialogue in MoinMoin wiki.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"moinmoin","vendor":"moinmo"},{"product":"leap","vendor":"opensuse"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects moin","id":"CVE-2017-5934","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","opensuse:leap"],"type":"xss","year":"2017"},"n_packages":3,"n_references":6,"next":{"headline":"OpenStack Nova-LXD bypass security restrictions","id":"CVE-2017-5936"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.10"],"introduced":["0"],"last_affected":[],"package":"moin","purl":null,"source":"GHSA-42fp-4hm3-j8r7"},{"ecosystem":"PyPI","fixed":["1.9.10"],"introduced":["0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"GHSA-42fp-4hm3-j8r7"},{"ecosystem":"PyPI","fixed":["1.9.10"],"introduced":["0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"PYSEC-2018-47"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2017-5933"},"products":["n/a"],"published":"2018-10-15","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the GUI editor link dialogue in MoinMoin wiki.","url":"https://insights.sbomify.com/CVE-2017-5934/"}