# CVE-2017-5934: Moderate severity vulnerability that affects moin

> Remote attackers can inject arbitrary web script or HTML via the GUI editor link dialogue in MoinMoin wiki.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DLA-1546-1, DSA-4318-1, GHSA-42fp-4hm3-j8r7, PYSEC-2018-47, UBUNTU-CVE-2017-5934, USN-3794-1

## What is CVE-2017-5934?

CVE-2017-5934 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 15 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-5934?

3 open source packages ship an affected version, including moin. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.9.10 |
| `moin` | PyPI | All versions | 1.9.10 |
| `moin` | PyPI | All versions | 1.9.10 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Moinmo Moinmoin, Opensuse Leap.

## How do I fix CVE-2017-5934?

Upgrade moin to 1.9.10 or later.

## Is CVE-2017-5934 being exploited?

There is no known exploitation of CVE-2017-5934 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5934 and fix it if it is affected.

What it is: CVE-2017-5934 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 15 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-5934 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.9.10
- moin (PyPI): affected all versions; fixed in 1.9.10
- moin (PyPI): affected all versions; fixed in 1.9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5934/ (Markdown: https://insights.sbomify.com/CVE-2017-5934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5934
- OSV: https://osv.dev/vulnerability/CVE-2017-5934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5934/
Summaries are generated and may contain mistakes; the official description above is the record.
