{"answers":{"affected":"3 open source packages ship an affected version, including nova-lxd. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-5936 in the wild and no public exploit code.","fix":"Upgrade nova-lxd to 13.1.1 or later.","what":"CVE-2017-5936 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 12 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-5936 and fix it if it is affected.\n\nWhat it is: CVE-2017-5936 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 12 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-5936 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nova-lxd (PyPI): affected all versions; fixed in 13.1.1\n- nova-lxd (PyPI): affected all versions; fixed in 13.1.1\n- nova-lxd (PyPI): affected all versions; fixed in 13.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-5936/ (Markdown: https://insights.sbomify.com/CVE-2017-5936/index.md)","id":"CVE-2017-5936","markdown":"https://insights.sbomify.com/CVE-2017-5936/index.md","name":"CVE-2017-5936","record":{"aliases":["GHSA-6xc7-4cx8-j3xc","PYSEC-2017-21","UBUNTU-CVE-2017-5936","USN-3195-1"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenStack Nova-LXD","requires_auth":"none","summary":"Remote attackers can bypass Neutron security group restrictions in OpenStack Nova-LXD due to incorrect veth pair naming.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"nova-lxd","vendor":"openstack"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[],"description":"OpenStack Nova-LXD before 13.1.1 uses the wrong name for the veth pairs when applying Neutron security group rules for instances, which allows remote attackers to bypass intended security restrictions.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenStack Nova-LXD bypass security restrictions","id":"CVE-2017-5936","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"security_feature_bypass","year":"2017"},"n_packages":3,"n_references":5,"next":{"headline":"Null dereference in n/a","id":"CVE-2017-5937"},"packages":[{"ecosystem":"PyPI","fixed":["13.1.1"],"introduced":["0"],"last_affected":[],"package":"nova-lxd","purl":null,"source":"GHSA-6xc7-4cx8-j3xc"},{"ecosystem":"PyPI","fixed":["13.1.1"],"introduced":["0"],"last_affected":[],"package":"nova-lxd","purl":"pkg:pypi/nova-lxd","source":"GHSA-6xc7-4cx8-j3xc"},{"ecosystem":"PyPI","fixed":["13.1.1"],"introduced":["0"],"last_affected":[],"package":"nova-lxd","purl":"pkg:pypi/nova-lxd","source":"PYSEC-2017-21"}],"prev":{"headline":"Moderate severity vulnerability that affects moin","id":"CVE-2017-5934"},"products":["n/a"],"published":"2017-04-12","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can bypass Neutron security group restrictions in OpenStack Nova-LXD due to incorrect veth pair naming.","url":"https://insights.sbomify.com/CVE-2017-5936/"}