# CVE-2017-5954: Code Execution Through IIFE in serialize-to-js

> Attackers can achieve arbitrary code execution by passing malicious JavaScript objects to the deserialize function in the serialize-to-js package.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mm62-wxc8-cf7m

## What is CVE-2017-5954?

CVE-2017-5954 is a critical unsafe deserialization vulnerability in n/a, published on 10 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the serialize-to-js package 0.5.0 for Node.js. Untrusted data passed into the deserialize() function can be exploited to achieve arbitrary code execution by passing a JavaScript Object with an Immediately Invoked Function Expression (IIFE).

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-5954?

2 open source packages ship an affected version, including serialize-to-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `serialize-to-js` | npm | All versions | 1.0.0 |
| `serialize-to-js` | npm | All versions | 1.0.0 |

Products: Serialize-to-Js Project Serialize-to-Js.

## How do I fix CVE-2017-5954?

Upgrade serialize-to-js to 1.0.0 or later.

## Is CVE-2017-5954 being exploited?

There is no known exploitation of CVE-2017-5954 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-15871](https://insights.sbomify.com/CVE-2017-15871/): Denial of service in n/a (high 7.5)
- [CVE-2019-16772](https://insights.sbomify.com/CVE-2019-16772/): regular expressions Cross-Site Scripting (XSS) vulnerability in serialize-to-js (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-5954 and fix it if it is affected.

What it is: CVE-2017-5954 is a critical unsafe deserialization vulnerability in n/a, published on 10 Feb 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-5954 in the wild and no public exploit code.

Affected packages and fixed versions:
- serialize-to-js (npm): affected all versions; fixed in 1.0.0
- serialize-to-js (npm): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-5954/ (Markdown: https://insights.sbomify.com/CVE-2017-5954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-5954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-5954
- OSV: https://osv.dev/vulnerability/CVE-2017-5954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-5954/
Summaries are generated and may contain mistakes; the official description above is the record.
