{"answers":{"affected":"2 open source packages ship an affected version, including paypal/merchant-sdk-php. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-6099 in the wild and no public exploit code.","fix":"Upgrade paypal/merchant-sdk-php to 3.12.0 or later.","what":"CVE-2017-6099 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-6099 and fix it if it is affected.\n\nWhat it is: CVE-2017-6099 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-6099 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paypal/merchant-sdk-php (Packagist): affected from 3.0.0; fixed in 3.12.0\n- paypal/merchant-sdk-php (Packagist): affected from 3.0.0; fixed in 3.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6099/ (Markdown: https://insights.sbomify.com/CVE-2017-6099/index.md)","id":"CVE-2017-6099","markdown":"https://insights.sbomify.com/CVE-2017-6099/index.md","name":"CVE-2017-6099","record":{"aliases":["GHSA-p4g7-wjhq-9r2h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PayPal PHP SDK","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the token parameter in the PayPal PHP Merchant SDK.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"merchant-sdk-php","vendor":"paypal"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote attackers to inject arbitrary web script or HTML via the token parameter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PayPal PHP Merchant SDK Cross-site scripting (XSS) vulnerability","id":"CVE-2017-6099","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Server-side request forgery in n/a","id":"CVE-2017-6100"},"packages":[{"ecosystem":"Packagist","fixed":["3.12.0"],"introduced":["3.0.0"],"last_affected":[],"package":"paypal/merchant-sdk-php","purl":null,"source":"GHSA-p4g7-wjhq-9r2h"},{"ecosystem":"Packagist","fixed":["3.12.0"],"introduced":["3.0.0"],"last_affected":[],"package":"paypal/merchant-sdk-php","purl":"pkg:composer/paypal/merchant-sdk-php","source":"GHSA-p4g7-wjhq-9r2h"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2017-6098"},"products":["n/a"],"published":"2017-02-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the token parameter in the PayPal PHP Merchant SDK.","url":"https://insights.sbomify.com/CVE-2017-6099/"}