# CVE-2017-6099: PayPal PHP Merchant SDK Cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML via the token parameter in the PayPal PHP Merchant SDK.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Feb 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-p4g7-wjhq-9r2h

## What is CVE-2017-6099?

CVE-2017-6099 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote attackers to inject arbitrary web script or HTML via the token parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-6099?

2 open source packages ship an affected version, including paypal/merchant-sdk-php. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paypal/merchant-sdk-php` | Packagist | From 3.0.0 | 3.12.0 |
| `paypal/merchant-sdk-php` | Packagist | From 3.0.0 | 3.12.0 |

Products: Paypal Merchant-Sdk-Php.

## How do I fix CVE-2017-6099?

Upgrade paypal/merchant-sdk-php to 3.12.0 or later.

## Is CVE-2017-6099 being exploited?

There is no known exploitation of CVE-2017-6099 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6099 and fix it if it is affected.

What it is: CVE-2017-6099 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-6099 in the wild and no public exploit code.

Affected packages and fixed versions:
- paypal/merchant-sdk-php (Packagist): affected from 3.0.0; fixed in 3.12.0
- paypal/merchant-sdk-php (Packagist): affected from 3.0.0; fixed in 3.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6099/ (Markdown: https://insights.sbomify.com/CVE-2017-6099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6099
- OSV: https://osv.dev/vulnerability/CVE-2017-6099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6099/
Summaries are generated and may contain mistakes; the official description above is the record.
