{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-6188 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-6188 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 22 Feb 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-6188 and fix it if it is affected.\n\nWhat it is: CVE-2017-6188 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 22 Feb 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-6188 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6188/ (Markdown: https://insights.sbomify.com/CVE-2017-6188/index.md)","id":"CVE-2017-6188","markdown":"https://insights.sbomify.com/CVE-2017-6188/index.md","name":"CVE-2017-6188","record":{"aliases":["DEBIAN-CVE-2017-6188","DLA-836-1","DSA-3794-1","GHSA-vpvg-79jp-cjw8","MGASA-2017-0101","UBUNTU-CVE-2017-6188","USN-3215-1","openSUSE-SU-2024:11067-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Munin monitoring tool","requires_auth":"low_privilege","summary":"Attackers can overwrite arbitrary files accessible to the web user by manipulating GET parameters when CGI graphs are enabled.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"munin","vendor":"munin-monitoring"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2017-6188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"path_traversal","year":"2017"},"n_packages":1,"n_references":5,"next":{"headline":"Other in n/a","id":"CVE-2017-6189"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.0.66-3.5"],"introduced":["0"],"last_affected":[],"package":"munin","purl":"pkg:rpm/opensuse/munin\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11067-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-6187"},"products":["n/a"],"published":"2017-02-22","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can overwrite arbitrary files accessible to the web user by manipulating GET parameters when CGI graphs are enabled.","url":"https://insights.sbomify.com/CVE-2017-6188/"}