# CVE-2017-6320: Command injection in n/a

> Authenticated attackers can execute arbitrary shell commands and gain root privileges via unsanitized input in the delete_assessment command.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f3r9-jfc2-vg93

## What is CVE-2017-6320?

CVE-2017-6320 is a high-severity command injection vulnerability in n/a, published on 18 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A remote command injection vulnerability exists in the Barracuda Load Balancer product line (confirmed on v5.4.0.004 (2015-11-26) and v6.0.1.006 (2016-08-19); fixed in 6.1.0.003 (2017-01-17)) in which an authenticated user can execute arbitrary shell commands and gain root privileges. The vulnerability stems from unsanitized data being processed in a system call when the delete_assessment command is issued.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2017-6320?

It affects 1 product.


Products: Barracuda Load Balancer Adc.

## How do I fix CVE-2017-6320?

No fix has been published for CVE-2017-6320 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-6320 being exploited?

There is no known exploitation of CVE-2017-6320 in the wild and no public exploit code.

Public exploit code:

- Barracuda Load Balancer Firmware < 6.0.1.006 - Remote Command Injection (Metasploit) (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6320 and fix it if it is affected.

What it is: CVE-2017-6320 is a high-severity command injection vulnerability in n/a, published on 18 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6320 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6320/ (Markdown: https://insights.sbomify.com/CVE-2017-6320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6320
- OSV: https://osv.dev/vulnerability/CVE-2017-6320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6320/
Summaries are generated and may contain mistakes; the official description above is the record.
