CVE-2017-6377 Drupal editor module incorrectly checks access to inline private files
High 7.5
Published
Updated
Check this codebase for CVE-2017-6377 and fix it if it is affected.
What it is: CVE-2017-6377 is a high-severity vulnerability in Drupal Drupal, published on 16 Mar 2017.
Exploitation: There is no known exploitation of CVE-2017-6377 in the wild and no public exploit code.
Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.2.0; fixed in 8.2.7
- drupal/core (Packagist): affected from 8.2.0; fixed in 8.2.7
- drupal/drupal (Packagist): affected from 8.2.0; fixed in 8.2.7
- drupal/drupal (Packagist): affected from 8.2.0; fixed in 8.2.7
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2017-6377/ (Markdown: https://insights.sbomify.com/CVE-2017-6377/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2017-6377?
CVE-2017-6377 is a high-severity vulnerability in Drupal Drupal, published on 16 Mar 2017.
Official description
When adding a private file via the editor in Drupal 8.2.x before 8.2.7, the editor will not correctly check access for the file being attached, resulting in an access bypass.
Weakness: CWE-863
Which versions are affected by CVE-2017-6377?
4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 8.2.0 | 8.2.7 |
drupal/core Packagist | From 8.2.0 | 8.2.7 |
drupal/drupal Packagist | From 8.2.0 | 8.2.7 |
drupal/drupal Packagist | From 8.2.0 | 8.2.7 |
Products include Drupal Drupal.
How do I fix CVE-2017-6377?
Upgrade drupal/core to 8.2.7 or later.
Is CVE-2017-6377 being exploited?
There is no known exploitation of CVE-2017-6377 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as GHSA-w7qx-vwr9-2j3r.