{"answers":{"affected":"4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-6381 in the wild and no public exploit code.","fix":"Upgrade drupal/core to 8.2.7 or later.","what":"CVE-2017-6381 is a high-severity code injection vulnerability in Drupal Drupal, published on 16 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-6381 and fix it if it is affected.\n\nWhat it is: CVE-2017-6381 is a high-severity code injection vulnerability in Drupal Drupal, published on 16 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-6381 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 8.0; fixed in 8.2.7\n- drupal/core (Packagist): affected from 8.0; fixed in 8.2.7\n- drupal/drupal (Packagist): affected from 8.0; fixed in 8.2.7\n- drupal/drupal (Packagist): affected from 8.0; fixed in 8.2.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6381/ (Markdown: https://insights.sbomify.com/CVE-2017-6381/index.md)","id":"CVE-2017-6381","markdown":"https://insights.sbomify.com/CVE-2017-6381/index.md","name":"CVE-2017-6381","record":{"aliases":["GHSA-rhx9-3qf7-r3j7","UBUNTU-CVE-2017-6381"],"analysis":{"component_type":"web_application","fix_type":"configuration_change","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Drupal core","requires_auth":"none","summary":"Remote code execution possible in Drupal via vulnerable PHPUnit dependency if development files are exposed in production.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"drupal","vendor":"drupal"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the \u003csiteroot\u003e/vendor/phpunit directory from your production deployments","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal Remote code execution","id":"CVE-2017-6381","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"drupal:drupal","products":["drupal:drupal"],"type":"code_injection","year":"2017"},"n_packages":4,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-6384"},"packages":[{"ecosystem":"Packagist","fixed":["8.2.7"],"introduced":["8.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-rhx9-3qf7-r3j7"},{"ecosystem":"Packagist","fixed":["8.2.7"],"introduced":["8.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-rhx9-3qf7-r3j7"},{"ecosystem":"Packagist","fixed":["8.2.7"],"introduced":["8.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-rhx9-3qf7-r3j7"},{"ecosystem":"Packagist","fixed":["8.2.7"],"introduced":["8.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-rhx9-3qf7-r3j7"}],"prev":{"headline":"Drupal Cross-Site Request Forgery (CSRF)","id":"CVE-2017-6379"},"products":["Drupal Core"],"published":"2017-03-16","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Drupal"]},"summary":"Remote code execution possible in Drupal via vulnerable PHPUnit dependency if development files are exposed in production.","url":"https://insights.sbomify.com/CVE-2017-6381/"}