{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-6410 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-6410 is a medium-severity vulnerability in n/a, published on 2 Mar 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-6410 and fix it if it is affected.\n\nWhat it is: CVE-2017-6410 is a medium-severity vulnerability in n/a, published on 2 Mar 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-6410 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6410/ (Markdown: https://insights.sbomify.com/CVE-2017-6410/index.md)","id":"CVE-2017-6410","markdown":"https://insights.sbomify.com/CVE-2017-6410/index.md","name":"CVE-2017-6410","record":{"aliases":["DEBIAN-CVE-2017-6410","GHSA-6qcm-9vg4-jxv8","MGASA-2017-0079","UBUNTU-CVE-2017-6410","USN-3223-1","openSUSE-SU-2017:0677-1","openSUSE-SU-2017:0680-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"KDE kio library","requires_auth":"none","summary":"Remote attackers can obtain sensitive information, such as credentials, via a crafted PAC file due to improper URL handling in KDE kio.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"kdelibs","vendor":"kde"},{"product":"kio","vendor":"kde"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-319","name":"Cleartext Transmission of Sensitive Information"}],"description":"kpac/script.cpp in KDE kio before 5.32 and kdelibs before 4.14.30 calls the PAC FindProxyForURL function with a full https URL (potentially including Basic Authentication credentials, a query string, or PATH_INFO), which allows remote attackers to obtain sensitive information via a crafted PAC file.","ecosystems":["SUSE:Package Hub 12 SP1","SUSE:Package Hub 12 SP2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2017-6410","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2017"},"n_packages":12,"n_references":3,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2017-6411"},"packages":[{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["4.14.25-5.3"],"introduced":["0"],"last_affected":[],"package":"kdelibs4","purl":"pkg:rpm/suse/kdelibs4\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2017:0677-1"},{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["4.14.25-5.3"],"introduced":["0"],"last_affected":[],"package":"kdelibs4","purl":"pkg:rpm/suse/kdelibs4\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2017:0680-1"},{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["4.14.25-5.3"],"introduced":["0"],"last_affected":[],"package":"kdelibs4-apidocs","purl":"pkg:rpm/suse/kdelibs4-apidocs\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2017:0677-1"},{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["4.14.25-5.3"],"introduced":["0"],"last_affected":[],"package":"kdelibs4-apidocs","purl":"pkg:rpm/suse/kdelibs4-apidocs\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2017:0680-1"},{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["5.26.0-5.1"],"introduced":["0"],"last_affected":[],"package":"kio","purl":"pkg:rpm/suse/kio\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2017:0677-1"},{"ecosystem":"SUSE:Package Hub 12 SP1","fixed":["5.26.0-5.1"],"introduced":["0"],"last_affected":[],"package":"kio","purl":"pkg:rpm/suse/kio\u0026distro=SUSE%20Package%20Hub%2012%20SP1","source":"openSUSE-SU-2017:0680-1"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["4.14.25-5.3"],"introduced":["0"],"last_affected":[],"package":"kdelibs4","purl":"pkg:rpm/suse/kdelibs4\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:0677-1"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["4.14.25-5.3"],"introduced":["0"],"last_affected":[],"package":"kdelibs4","purl":"pkg:rpm/suse/kdelibs4\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:0680-1"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["4.14.25-5.3"],"introduced":["0"],"last_affected":[],"package":"kdelibs4-apidocs","purl":"pkg:rpm/suse/kdelibs4-apidocs\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:0677-1"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["4.14.25-5.3"],"introduced":["0"],"last_affected":[],"package":"kdelibs4-apidocs","purl":"pkg:rpm/suse/kdelibs4-apidocs\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:0680-1"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["5.26.0-5.1"],"introduced":["0"],"last_affected":[],"package":"kio","purl":"pkg:rpm/suse/kio\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:0677-1"},{"ecosystem":"SUSE:Package Hub 12 SP2","fixed":["5.26.0-5.1"],"introduced":["0"],"last_affected":[],"package":"kio","purl":"pkg:rpm/suse/kio\u0026distro=SUSE%20Package%20Hub%2012%20SP2","source":"openSUSE-SU-2017:0680-1"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2017-6409"},"products":["n/a"],"published":"2017-03-02","related":[{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2009-2702","kev_date_added":null,"published":"2009-09-08"},{"cvss_score":7.5,"headline":"Command injection in n/a","id":"CVE-2004-1165","kev_date_added":null,"published":"2004-12-10"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2013-2074","kev_date_added":null,"published":"2014-02-05"},{"cvss_score":4.3,"headline":"Information disclosure in n/a","id":"CVE-2014-3494","kev_date_added":null,"published":"2014-07-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive information, such as credentials, via a crafted PAC file due to improper URL handling in KDE kio.","url":"https://insights.sbomify.com/CVE-2017-6410/"}