{"answers":{"affected":"2 open source packages ship an affected version, including inter-mediator/inter-mediator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-6484 in the wild and no public exploit code.","fix":"Upgrade inter-mediator/inter-mediator to 5.6 or later.","what":"CVE-2017-6484 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-6484 and fix it if it is affected.\n\nWhat it is: CVE-2017-6484 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-6484 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- inter-mediator/inter-mediator (Packagist): affected from 5.5; fixed in 5.6\n- inter-mediator/inter-mediator (Packagist): affected from 5.5; fixed in 5.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6484/ (Markdown: https://insights.sbomify.com/CVE-2017-6484/index.md)","id":"CVE-2017-6484","markdown":"https://insights.sbomify.com/CVE-2017-6484/index.md","name":"CVE-2017-6484","record":{"aliases":["GHSA-w969-pq6x-267j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"INTER-Mediator","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in user browsers via XSS in INTER-Mediator password reset functionality.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"inter-mediator","vendor":"inter-mediator"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple Cross-Site Scripting (XSS) issues were discovered in INTER-Mediator 5.5. The vulnerabilities exist due to insufficient filtration of user-supplied data (c and cred) passed to the \"INTER-Mediator-master/Auth_Support/PasswordReset/resetpassword.php\" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"INTER-Mediator Cross-Site Scripting (XSS)","id":"CVE-2017-6484","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-6485"},"packages":[{"ecosystem":"Packagist","fixed":["5.6"],"introduced":["5.5"],"last_affected":[],"package":"inter-mediator/inter-mediator","purl":null,"source":"GHSA-w969-pq6x-267j"},{"ecosystem":"Packagist","fixed":["5.6"],"introduced":["5.5"],"last_affected":[],"package":"inter-mediator/inter-mediator","purl":"pkg:composer/inter-mediator/inter-mediator","source":"GHSA-w969-pq6x-267j"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-6483"},"products":["n/a"],"published":"2017-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts in user browsers via XSS in INTER-Mediator password reset functionality.","url":"https://insights.sbomify.com/CVE-2017-6484/"}