CVE-2017-6746 Command injection in Cisco Web Security Appliance
Authenticated administrators can execute arbitrary commands with root privileges on Cisco Web Security Appliances via the web interface.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2017-6746?
CVE-2017-6746 is a high-severity command injection vulnerability in Cisco Web Security Appliance, published on 25 Jul 2017. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A vulnerability in the web interface of the Cisco Web Security Appliance (WSA) could allow an authenticated, remote attacker to perform command injection and elevate privileges to root. The attacker must authenticate with valid administrator credentials. Affected Products: Cisco AsyncOS Software 10.0 and later for WSA on both virtual and hardware appliances. More Information: CSCvd88862. Known Affected Releases: 10.1.0-204. Known Fixed Releases: 10.5.1-270 10.1.1-235.
Weakness: CWE-20
Which versions are affected by CVE-2017-6746?
It affects 1 product.
Products include Cisco Web Security Appliance.
How do I fix CVE-2017-6746?
No fix has been published for CVE-2017-6746 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2017-6746 being exploited?
There is no known exploitation of CVE-2017-6746 in the wild and no public exploit code.
Other vulnerabilities in Cisco Web Security Appliance
Sources
Also known as GHSA-gmcr-6x9x-76r5.