CVE-2017-6919 Drupal access control bypass vulnerability
Authenticated users can bypass access controls and modify data if the REST module is enabled and PATCH requests are allowed.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-6919?
CVE-2017-6919 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Drupal 8 before 8.2.8 and 8.3 before 8.3.1 allows critical access bypass by authenticated users if the RESTful Web Services (rest) module is enabled and the site allows PATCH requests.
Which versions are affected by CVE-2017-6919?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 8.0 | 8.2.8 |
drupal/core Packagist | From 8.0 | 8.2.8 |
drupal/core Packagist | From 8.3.0 | 8.3.1 |
drupal/core Packagist | From 8.3.0 | 8.3.1 |
drupal/drupal Packagist | From 8.0 | 8.2.8 |
drupal/drupal Packagist | From 8.0 | 8.2.8 |
2 more packages
drupal/drupal Packagist | From 8.3.0 | 8.3.1 |
drupal/drupal Packagist | From 8.3.0 | 8.3.1 |
Products include Drupal Drupal.
How do I fix CVE-2017-6919?
Upgrade drupal/core to a fixed version for your release line: 8.2.8 or 8.3.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2017-6919 being exploited?
There is no known exploitation of CVE-2017-6919 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as GHSA-6hpj-9xj7-2jxx.