{"answers":{"affected":"8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-6919 in the wild and no public exploit code.","fix":"Upgrade drupal/core to a fixed version for your release line: 8.2.8 or 8.3.1.","what":"CVE-2017-6919 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-6919 and fix it if it is affected.\n\nWhat it is: CVE-2017-6919 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-6919 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 8.0; fixed in 8.2.8\n- drupal/core (Packagist): affected from 8.0; fixed in 8.2.8\n- drupal/core (Packagist): affected from 8.3.0; fixed in 8.3.1\n- drupal/core (Packagist): affected from 8.3.0; fixed in 8.3.1\n- drupal/drupal (Packagist): affected from 8.0; fixed in 8.2.8\n- drupal/drupal (Packagist): affected from 8.0; fixed in 8.2.8\n- drupal/drupal (Packagist): affected from 8.3.0; fixed in 8.3.1\n- drupal/drupal (Packagist): affected from 8.3.0; fixed in 8.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6919/ (Markdown: https://insights.sbomify.com/CVE-2017-6919/index.md)","id":"CVE-2017-6919","markdown":"https://insights.sbomify.com/CVE-2017-6919/index.md","name":"CVE-2017-6919","record":{"aliases":["GHSA-6hpj-9xj7-2jxx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Drupal CMS","requires_auth":"low_privilege","summary":"Authenticated users can bypass access controls and modify data if the REST module is enabled and PATCH requests are allowed.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"drupal","vendor":"drupal"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"Drupal 8 before 8.2.8 and 8.3 before 8.3.1 allows critical access bypass by authenticated users if the RESTful Web Services (rest) module is enabled and the site allows PATCH requests.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal access control bypass vulnerability","id":"CVE-2017-6919","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"drupal:drupal","products":["drupal:drupal"],"type":"auth_bypass","year":"2017"},"n_packages":8,"n_references":3,"next":{"headline":"Drupal PECL YAML parser unsafe object handling","id":"CVE-2017-6920"},"packages":[{"ecosystem":"Packagist","fixed":["8.2.8"],"introduced":["8.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-6hpj-9xj7-2jxx"},{"ecosystem":"Packagist","fixed":["8.2.8"],"introduced":["8.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-6hpj-9xj7-2jxx"},{"ecosystem":"Packagist","fixed":["8.3.1"],"introduced":["8.3.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-6hpj-9xj7-2jxx"},{"ecosystem":"Packagist","fixed":["8.3.1"],"introduced":["8.3.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-6hpj-9xj7-2jxx"},{"ecosystem":"Packagist","fixed":["8.2.8"],"introduced":["8.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-6hpj-9xj7-2jxx"},{"ecosystem":"Packagist","fixed":["8.2.8"],"introduced":["8.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-6hpj-9xj7-2jxx"},{"ecosystem":"Packagist","fixed":["8.3.1"],"introduced":["8.3.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-6hpj-9xj7-2jxx"},{"ecosystem":"Packagist","fixed":["8.3.1"],"introduced":["8.3.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-6hpj-9xj7-2jxx"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2017-6918"},"products":["Drupal"],"published":"2017-04-20","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated users can bypass access controls and modify data if the REST module is enabled and PATCH requests are allowed.","url":"https://insights.sbomify.com/CVE-2017-6919/"}