# CVE-2017-6919: Drupal access control bypass vulnerability

> Authenticated users can bypass access controls and modify data if the REST module is enabled and PATCH requests are allowed.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6hpj-9xj7-2jxx

## What is CVE-2017-6919?

CVE-2017-6919 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Drupal 8 before 8.2.8 and 8.3 before 8.3.1 allows critical access bypass by authenticated users if the RESTful Web Services (rest) module is enabled and the site allows PATCH requests.

## Which versions are affected by CVE-2017-6919?

8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.0 | 8.2.8 |
| `drupal/core` | Packagist | From 8.0 | 8.2.8 |
| `drupal/core` | Packagist | From 8.3.0 | 8.3.1 |
| `drupal/core` | Packagist | From 8.3.0 | 8.3.1 |
| `drupal/drupal` | Packagist | From 8.0 | 8.2.8 |
| `drupal/drupal` | Packagist | From 8.0 | 8.2.8 |
| `drupal/drupal` | Packagist | From 8.3.0 | 8.3.1 |
| `drupal/drupal` | Packagist | From 8.3.0 | 8.3.1 |

Products: Drupal Drupal.

## How do I fix CVE-2017-6919?

Upgrade drupal/core to a fixed version for your release line: 8.2.8 or 8.3.1.

## Is CVE-2017-6919 being exploited?

There is no known exploitation of CVE-2017-6919 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6919 and fix it if it is affected.

What it is: CVE-2017-6919 is a high-severity authentication bypass vulnerability in Drupal Drupal, published on 20 Apr 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6919 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.0; fixed in 8.2.8
- drupal/core (Packagist): affected from 8.0; fixed in 8.2.8
- drupal/core (Packagist): affected from 8.3.0; fixed in 8.3.1
- drupal/core (Packagist): affected from 8.3.0; fixed in 8.3.1
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.2.8
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.2.8
- drupal/drupal (Packagist): affected from 8.3.0; fixed in 8.3.1
- drupal/drupal (Packagist): affected from 8.3.0; fixed in 8.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6919/ (Markdown: https://insights.sbomify.com/CVE-2017-6919/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6919
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6919
- OSV: https://osv.dev/vulnerability/CVE-2017-6919

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6919/
Summaries are generated and may contain mistakes; the official description above is the record.
