{"answers":{"affected":"4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-6920 in the wild and no public exploit code.","fix":"Upgrade drupal/core to 8.3.4 or later.","what":"CVE-2017-6920 is a critical unsafe deserialization vulnerability in Drupal Drupal, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-6920 and fix it if it is affected.\n\nWhat it is: CVE-2017-6920 is a critical unsafe deserialization vulnerability in Drupal Drupal, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-6920 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 8.0; fixed in 8.3.4\n- drupal/core (Packagist): affected from 8.0; fixed in 8.3.4\n- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.4\n- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-6920/ (Markdown: https://insights.sbomify.com/CVE-2017-6920/index.md)","id":"CVE-2017-6920","markdown":"https://insights.sbomify.com/CVE-2017-6920/index.md","name":"CVE-2017-6920","record":{"aliases":["GHSA-9c24-g32g-35rj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal core","requires_auth":"none","summary":"Remote attackers can execute arbitrary code in Drupal core due to unsafe handling of PHP objects by the PECL YAML parser.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"drupal","vendor":"drupal"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-19","name":null}],"description":"Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal PECL YAML parser unsafe object handling","id":"CVE-2017-6920","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"drupal:drupal","products":["drupal:drupal"],"type":"deserialization","year":"2017"},"n_packages":4,"n_references":3,"next":{"headline":"File REST resource does not properly validate","id":"CVE-2017-6921"},"packages":[{"ecosystem":"Packagist","fixed":["8.3.4"],"introduced":["8.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-9c24-g32g-35rj"},{"ecosystem":"Packagist","fixed":["8.3.4"],"introduced":["8.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-9c24-g32g-35rj"},{"ecosystem":"Packagist","fixed":["8.3.4"],"introduced":["8.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-9c24-g32g-35rj"},{"ecosystem":"Packagist","fixed":["8.3.4"],"introduced":["8.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-9c24-g32g-35rj"}],"prev":{"headline":"Drupal access control bypass vulnerability","id":"CVE-2017-6919"},"products":["Drupal Core"],"published":"2018-08-06","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Drupal.org"]},"summary":"Remote attackers can execute arbitrary code in Drupal core due to unsafe handling of PHP objects by the PECL YAML parser.","url":"https://insights.sbomify.com/CVE-2017-6920/"}