CVE-2017-6922 Files uploaded by anonymous users into a private file system can be accessed by other anonymous users
Anonymous users can access private files uploaded by other anonymous users if the site allows anonymous uploads to private storage.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-6922?
CVE-2017-6922 is a medium-severity missing authorization vulnerability in Debian Debian Linux, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Drupal core 8.x prior to 8.3.4 and Drupal core 7.x prior to 7.56; Private files that have been uploaded by an anonymous user but not permanently attached to content on the site should only be visible to the anonymous user that uploaded them, rather than all anonymous users. Drupal core did not previously provide this protection, allowing an access bypass vulnerability to occur. This issue is mitigated by the fact that in order to be affected, the site must allow anonymous users to upload files into a private file system.
Weakness: CWE-552
Which versions are affected by CVE-2017-6922?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0 | 7.56 |
drupal/core Packagist | From 7.0 | 7.56 |
drupal/core Packagist | From 8.0 | 8.3.4 |
drupal/core Packagist | From 8.0 | 8.3.4 |
drupal/drupal Packagist | From 7.0 | 7.56 |
drupal/drupal Packagist | From 7.0 | 7.56 |
2 more packages
drupal/drupal Packagist | From 8.0 | 8.3.4 |
drupal/drupal Packagist | From 8.0 | 8.3.4 |
Products include Debian Debian Linux, Drupal Drupal.
How do I fix CVE-2017-6922?
Upgrade drupal/core to a fixed version for your release line: 7.56 or 8.3.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2017-6922 being exploited?
There is no known exploitation of CVE-2017-6922 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DLA-1004-1, DSA-3897-1, GHSA-58f3-cx8p-h8jg, MGASA-2017-0198, UBUNTU-CVE-2017-6922.