# CVE-2017-6922: Files uploaded by anonymous users into a private file system can be accessed by other anonymous users

> Anonymous users can access private files uploaded by other anonymous users if the site allows anonymous uploads to private storage.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** DLA-1004-1, DSA-3897-1, GHSA-58f3-cx8p-h8jg, MGASA-2017-0198, UBUNTU-CVE-2017-6922

## What is CVE-2017-6922?

CVE-2017-6922 is a medium-severity missing authorization vulnerability in Debian Debian Linux, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Drupal core 8.x prior to 8.3.4 and Drupal core 7.x prior to 7.56; Private files that have been uploaded by an anonymous user but not permanently attached to content on the site should only be visible to the anonymous user that uploaded them, rather than all anonymous users. Drupal core did not previously provide this protection, allowing an access bypass vulnerability to occur. This issue is mitigated by the fact that in order to be affected, the site must allow anonymous users to upload files into a private file system.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2017-6922?

8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0 | 7.56 |
| `drupal/core` | Packagist | From 7.0 | 7.56 |
| `drupal/core` | Packagist | From 8.0 | 8.3.4 |
| `drupal/core` | Packagist | From 8.0 | 8.3.4 |
| `drupal/drupal` | Packagist | From 7.0 | 7.56 |
| `drupal/drupal` | Packagist | From 7.0 | 7.56 |
| `drupal/drupal` | Packagist | From 8.0 | 8.3.4 |
| `drupal/drupal` | Packagist | From 8.0 | 8.3.4 |

Products: Debian Debian Linux, Drupal Drupal.

## How do I fix CVE-2017-6922?

Upgrade drupal/core to a fixed version for your release line: 7.56 or 8.3.4.

## Is CVE-2017-6922 being exploited?

There is no known exploitation of CVE-2017-6922 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6922 and fix it if it is affected.

What it is: CVE-2017-6922 is a medium-severity missing authorization vulnerability in Debian Debian Linux, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6922 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0; fixed in 7.56
- drupal/core (Packagist): affected from 7.0; fixed in 7.56
- drupal/core (Packagist): affected from 8.0; fixed in 8.3.4
- drupal/core (Packagist): affected from 8.0; fixed in 8.3.4
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.56
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.56
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.4
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6922/ (Markdown: https://insights.sbomify.com/CVE-2017-6922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6922
- OSV: https://osv.dev/vulnerability/CVE-2017-6922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6922/
Summaries are generated and may contain mistakes; the official description above is the record.
