# CVE-2017-6924: REST API can bypass comment approval - Access Bypass - Moderately Critical

> Attackers can post approved comments via REST API without proper permissions if the REST module is enabled.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p8g6-5mg7-9r5q

## What is CVE-2017-6924?

CVE-2017-6924 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 15 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Drupal 8 prior to 8.3.7; When using the REST API, users without the correct permission can post comments via REST that are approved even if the user does not have permission to post approved comments. This issue only affects sites that have the RESTful Web Services (rest) module enabled, the comment entity REST resource enabled, and where an attacker can access a user account on the site with permissions to post comments, or where anonymous users can post comments.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2017-6924?

4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.0 | 8.3.7 |
| `drupal/core` | Packagist | From 8.0 | 8.3.7 |
| `drupal/drupal` | Packagist | From 8.0 | 8.3.7 |
| `drupal/drupal` | Packagist | From 8.0 | 8.3.7 |

Products: Drupal Drupal.

## How do I fix CVE-2017-6924?

Upgrade drupal/core to 8.3.7 or later.

## Is CVE-2017-6924 being exploited?

There is no known exploitation of CVE-2017-6924 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6924 and fix it if it is affected.

What it is: CVE-2017-6924 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 15 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6924 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.0; fixed in 8.3.7
- drupal/core (Packagist): affected from 8.0; fixed in 8.3.7
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.7
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6924/ (Markdown: https://insights.sbomify.com/CVE-2017-6924/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6924
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6924
- OSV: https://osv.dev/vulnerability/CVE-2017-6924

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6924/
Summaries are generated and may contain mistakes; the official description above is the record.
