# CVE-2017-6925: Drupal Entity access bypass for entities that do not have UUIDs or have protected revisions

> Attackers can bypass access controls to view, create, update, or delete specific entities in Drupal 8 core.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f4qx-jqfq-7785

## What is CVE-2017-6925?

CVE-2017-6925 is a critical missing authorization vulnerability in Drupal Drupal, published on 15 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In versions of Drupal 8 core prior to 8.3.7; There is a vulnerability in the entity access system that could allow unwanted access to view, create, update, or delete entities. This only affects entities that do not use or do not have UUIDs, and entities that have different access restrictions on different revisions of the same entity.

## Which versions are affected by CVE-2017-6925?

4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.0 | 8.3.7 |
| `drupal/core` | Packagist | From 8.0 | 8.3.7 |
| `drupal/drupal` | Packagist | From 8.0 | 8.3.7 |
| `drupal/drupal` | Packagist | From 8.0 | 8.3.7 |

Products: Drupal Drupal.

## How do I fix CVE-2017-6925?

Upgrade drupal/core to 8.3.7 or later.

## Is CVE-2017-6925 being exploited?

There is no known exploitation of CVE-2017-6925 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6925 and fix it if it is affected.

What it is: CVE-2017-6925 is a critical missing authorization vulnerability in Drupal Drupal, published on 15 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6925 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.0; fixed in 8.3.7
- drupal/core (Packagist): affected from 8.0; fixed in 8.3.7
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.7
- drupal/drupal (Packagist): affected from 8.0; fixed in 8.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6925/ (Markdown: https://insights.sbomify.com/CVE-2017-6925/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6925
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6925
- OSV: https://osv.dev/vulnerability/CVE-2017-6925

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6925/
Summaries are generated and may contain mistakes; the official description above is the record.
