CVE-2017-6926 Drupal Comment reply form allows access to restricted content
Users with comment permissions can view and comment on restricted content, requiring the comment system to be enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-6926?
CVE-2017-6926 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Drupal versions 8.4.x versions before 8.4.5 users with permission to post comments are able to view content and comments they do not have access to, and are also able to add comments to this content. This vulnerability is mitigated by the fact that the comment system must be enabled and the attacker must have permission to post comments.
Weakness: CWE-200
Which versions are affected by CVE-2017-6926?
8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0 | 7.57 |
drupal/core Packagist | From 7.0 | 7.57 |
drupal/core Packagist | From 8.4.0 | 8.4.5 |
drupal/core Packagist | From 8.4.0 | 8.4.5 |
drupal/drupal Packagist | From 7.0 | 7.57 |
drupal/drupal Packagist | From 7.0 | 7.57 |
2 more packages
drupal/drupal Packagist | From 8.4.0 | 8.4.5 |
drupal/drupal Packagist | From 8.4.0 | 8.4.5 |
Products include Drupal Drupal.
How do I fix CVE-2017-6926?
Upgrade drupal/core to a fixed version for your release line: 7.57 or 8.4.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2017-6926 being exploited?
There is no known exploitation of CVE-2017-6926 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as GHSA-2p28-5mvp-2j2r.