# CVE-2017-6926: Drupal Comment reply form allows access to restricted content

> Users with comment permissions can view and comment on restricted content, requiring the comment system to be enabled.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-2p28-5mvp-2j2r

## What is CVE-2017-6926?

CVE-2017-6926 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Drupal versions 8.4.x versions before 8.4.5 users with permission to post comments are able to view content and comments they do not have access to, and are also able to add comments to this content. This vulnerability is mitigated by the fact that the comment system must be enabled and the attacker must have permission to post comments.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-6926?

8 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0 | 7.57 |
| `drupal/core` | Packagist | From 7.0 | 7.57 |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/core` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/drupal` | Packagist | From 7.0 | 7.57 |
| `drupal/drupal` | Packagist | From 7.0 | 7.57 |
| `drupal/drupal` | Packagist | From 8.4.0 | 8.4.5 |
| `drupal/drupal` | Packagist | From 8.4.0 | 8.4.5 |

Products: Drupal Drupal.

## How do I fix CVE-2017-6926?

Upgrade drupal/core to a fixed version for your release line: 7.57 or 8.4.5.

## Is CVE-2017-6926 being exploited?

There is no known exploitation of CVE-2017-6926 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-6926 and fix it if it is affected.

What it is: CVE-2017-6926 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 1 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-6926 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0; fixed in 7.57
- drupal/core (Packagist): affected from 7.0; fixed in 7.57
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/core (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57
- drupal/drupal (Packagist): affected from 7.0; fixed in 7.57
- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5
- drupal/drupal (Packagist): affected from 8.4.0; fixed in 8.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-6926/ (Markdown: https://insights.sbomify.com/CVE-2017-6926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-6926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-6926
- OSV: https://osv.dev/vulnerability/CVE-2017-6926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-6926/
Summaries are generated and may contain mistakes; the official description above is the record.
